In previous iterations of Lubuntu, that is, pre-QT, the network manager had a GUI which made it deadsimple to install a mobile-broadband SIM card USB receiver, when you clicked the "edit connections" on the connections icon in the panel, you'd get this:

old networkmanager After choosing "Mobile Broadband", there was a very easy guide - it even included presets for the internetprovider in my country! (Denmark)

In Lubuntu 18.10 and 19.04, doing the same drops you into terminal and presents you with this:

enter image description here

Some of the possibilities are the same, but the non-GUI menu does not have "Mobile Broadband". The possible connection types in the CLI networkmanager, that can't be seen are: Bridge - IP tunnel - Team - VLAN

I'm guessing/hoping it's because it's really just a popular special case of one of the other possibilities, so it's included in the GUI version from 18.04, but not in the 18.10+.

I just don't now how to proceed from here, can a kind soul help? I'd really like to use great new QT enviroment but I need to be able to connect to mobile broadband. Thank you.

  • What are the possibilities below "Bond" .. try to scroll down.
    – Soren A
    Apr 21, 2019 at 10:16
  • question updated :)
    – emilBeBri
    Apr 22, 2019 at 9:28
  • Can you help me with this? askubuntu.com/questions/1193096/…
    – Sree Ram
    Dec 19, 2019 at 15:28
  • Try the the accepted answer just below? that gives you a GUI at least, which will probably be easier.
    – emilBeBri
    Dec 19, 2019 at 17:18

4 Answers 4


I just installed Lubuntu 19 and still didn't have the GUI by default. So I had to install it via

sudo apt install network-manager-gnome

Network Connection GUI

  • 1
    In case also people are looking to add VPN functionality, at least for Lubuntu 19 I had to do some additional installations sudo apt-get install openvpn network-manager-openvpn network-manager-openvpn-gnome and sudo apt-get install network-manager-pptp-gnome
    – wyrml4
    Nov 18, 2019 at 21:24

Hoop jumping galore just to post, jeesh. Discourages participation.

Anyway I ran into this same thing trying to tether my 3G cell phone. Might mention you SHOULD be able to connect running wvdial from command line assuming you have correct wvdial.conf file setup.

"Should" being the operative word. I copied exact wvdial.conf file from another Linux that has no problem connecting and wvdial on Lubuntu 19.04 couldn't seem to read it. Just errored out using some default claiming malformed input line. I tried apt-get uninstall wvdial and uninstalled it. The apt-get install wvdial to reinstall it. Same difference. Ok, so tried installing kppp front end despite its huge size (lot KDE libraries). It could talk to my cell phone as a modem, if I first nuked the wvdial.conf file. But it crashed if I tried to setup an account. So then installed gnome-ppp. It couldn't see or talk to phone.

Oh should say WiFi connection works fine in Lubuntu. That's how I connected to use apt-get, used full Ubuntu 18.04 on one computer tethered to my cell and created a hotspot and then connected to that hotspot on another computer with Lubuntu. I give lot credit to whoever did network manager interface in Ubuntu. That works great. Especially cool that one button hotspot thing.

UPDATE EDIT: Ok I just had to figure why I couldnt connect with wvdial in Lubuntu.

Lubuntu is still Ubuntu and Ubuntu likes to play big brother and do the "mother may I" game.

Meaning you cant directly create a /etc/wvdial.conf file. You have to delete any wvdial.conf file you find, then "sudo wvdialconf /etc/wvdial.conf" command. Then this causes search for the modem (cell phone). It talks to it and when its happy, it then finds no current wvdial.conf file, so creates a wvdial.conf (configuration file) that wvdial can read without error. Now however you have to become root again and edit it putting in necessary info for your phone data account. Easiest way is to open file manager as root. Click on the configuration file, edit it and save. Luckily I already found a configuration file that works in wvdial for my phone as modem. I just erased all the crap below the [Dialer Defaults] header that was auto created and pasted in the file with correct readings in correct places. Save. Now "sudo wvdial" and it can read this configuration file so connects! I can surf.

I swear it took me the longest time to figure out why wvdial wouldnt use my created from whole cloth configuration file. Its a Ubuntu thing. Either that or I am just old and remember wvdial from the dialup days long ago when I could create a configuration file manually and have it recognized and functional without the hoop jumping. But IT WORKS!

Now I did find another way to do this from about ten years ago using what was called sakis3g. You can do search here on forum and get some mentions of it. The website disappeared back in 2013, but with lot searching you can still find copy of it compiled and the sources for it if you want to compile it. I got it running via command line but it crashed trying to use the gui. Didnt put time into seeing if I could make it work completely in command line. Probably could.

Also the tray connection applet in Lubuntu is just a crude front end for Network Manager so think there is also way to use Network Manager via command line. Again I didnt follow up on that as I was frustrated not getting my familiar wvdial to work and wanted answer to that most of all.

But yes I can understand you not wanting to deal with this if you arent comfortable working in command line. There is no easy gui way of doing this unless you have better luck with sakis3G gui than I did. I am sure next release of Lubuntu will have this problem corrected. We can't be only ones wanting to use mobile broadband. Good luck.

SECOND UPDATE: Oh found another alternative. Called ConnMan and needs ofono plugin and there is a gui frontend CMST. I played with it a little, but apparently its not really used a lot for tethering 3G phone so couldnt find easy way to make it work. It supposedly does, but since I have wvdial working to connect me, not going to spend time. But hey here is pretty much all alternatives in this post now so good luck anybody running across it.

  • thanks, I checked out wvdial, but seems too complicated for my skill level. I think I'll just stay with 18.04, since - too me very surprising - nobody has a straight out answer for this. And hope they re-create the wonderfully user-friendly GUI from the pre-QT era in one of the next versions. Here's to hope.
    – emilBeBri
    Apr 25, 2019 at 17:15

I found a very simple solution. The modem-manager-gnome should be installed and the Mobile Broadband connection with Nokia 302 Asha works on Lubuntu 19.04.

  • I had to find another solution and sold my Huwaei mobile broadband USB modem, so I can't verify wether it works more universally. But I'll mark it as the answer anyway, seems legit. :) so basically you just sudo apt-get install modem-manager-gnome, and then it's possible to do it from the panel-menu as per usual?
    – emilBeBri
    Jul 10, 2019 at 17:34

In case it helps someone, I solved it by using the GUI network manager, which i don't know why is not enabled by default instead of the CLI network manager in lubuntu. To do so, open a terminal (ctrl + alt + t ) and type:


This opens the ubuntu network manager, with all options. It helped me to configure WPA2 Enterprise, wich is not supported in the CLI mode.

  • very nice, thank you! how strange that it is enabled from 19.04 and onwards. maybe I should file it as a bug report, it's not exactly newbie-friendly.
    – emilBeBri
    Sep 19, 2019 at 6:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .