10

Just finished the upgrade to 19.04 and have almost everything working.

If I use the Windows/Super key to open the activities menu the system becomes unusable. I can swap windows, but can't interact with them at all. If I press escape the search box stays on the desktop.

10

This was caused by a gnome extension workspace grid. Removed extension and solved issue. When viewing system logs was seeing message like this:

Apr 20 21:07:31 name gnome-shell[2382]: JS ERROR: TypeError: child is null#012getNonExpandedWidth@resource:///org/gnome/shell/ui/overviewControls.js:282:9#012_updateWorkspacesGeometry@resource:///org/gnome/shell/ui/overviewControls.js:448:31#012vfunc_allocate@resource:///org/gnome/shell/ui/overviewControls.js:391:9#012_updateSwitchUserSubMenu@resource:///org/gnome/shell/ui/status/system.js:167:9
Apr 20 21:07:31 name gnome-shell[2382]: JS ERROR: TypeError: child is null#012getNonExpandedWidth@resource:///org/gnome/shell/ui/overviewControls.js:282:9#012_updateWorkspacesGeometry@resource:///org/gnome/shell/ui/overviewControls.js:448:31#012vfunc_allocate@resource:///org/gnome/shell/ui/overviewControls.js:391:9
  • My Issue resolved after deleting CPU Info & Workspace grid extensions. Thank you, was almost about to reinstall OS. – Amandeep Singh May 9 at 9:32
  • Workspace grid does not support Gnome 3.32, please consider using workspace-matrix instead extensions.gnome.org/extension/1485/workspace-matrix – zakkak Jun 14 at 20:20
  • Thanks so much! @ubuntu devs A bad extension shouldn't be able to make literally everything unusable – k_g Sep 27 at 11:12
0

For other reading this, I found that if you do super-L (lock screen) then Gnome will recover. I think it restarts Gnome (like logging out and back in) by the look of it but saves a reboot.

Give it 15secs or so wait and it comes back. Pain in the backside though. Will investigate the above fix!

  • 1
    Yep removing WS Grid fixed it here, thanks MrDrPenguin – user957055 May 21 at 9:56
0

To escape this situation, you can also press Alt+F2, type r and press Enter. This restarts Gnome, but it is a gentle and fast restart, your apps remain open.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.