2

I have a question very similar to (15.04 VMWare Player "unable to start services" error) in that the modules cannot be compiled.

However, the top solution does not work for me. Error

Here is the terminal commands that I used:

root@LesserArk:~# uname -r 
5.0.0-13-generic
root@LesserArk:~# man dkms
root@LesserArk:~# curl https://pastebin.com/raw/Z1ihzbcE -o /tmp/vmnet-3.19.patch
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1646    0  1646    0     0   4485      0 --:--:-- --:--:-- --:--:--  4485
root@LesserArk:~# 
root@LesserArk:~# cd /usr/lib/vmware/modules/source
root@LesserArk:/usr/lib/vmware/modules/source# tar -xf vmnet.tar
root@LesserArk:/usr/lib/vmware/modules/source# cd vmnet-only
root@LesserArk:/usr/lib/vmware/modules/source/vmnet-only# patch -p0 -i /tmp/vmnet-3.19.patch
(Stripping trailing CRs from patch; use --binary to disable.)
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -ur vmnet-only.a/driver.c vmnet-only/driver.c
|--- vmnet-only.a/driver.c      2014-11-20 20:13:56.000000000 -0500
|+++ vmnet-only/driver.c        2015-02-09 15:40:10.916640592 -0500
--------------------------
File to patch: 
Skip this patch? [y] y
Skipping patch.
2 out of 2 hunks ignored
(Stripping trailing CRs from patch; use --binary to disable.)
can't find file to patch at input line 45
  • Welcome to AskUbuntu! When the top solution doesn't work, check the next one. Cheers! – Elder Geek Apr 25 '19 at 13:58
9

Well I was having the same issue, and this could be a possible solution. The same workaround has also been accepted as the solution in VMware communities. From Charly's answer on Installing VMware on 18.04: Failed to build vmmon:

Create a script file based on mkucebek's github sources, and run it each time it's needed, usually when you install a new kernel:

#!/bin/bash 
VMWARE_VERSION=workstation-15.0.4
TMP_FOLDER=/tmp/patch-vmware
rm -fdr $TMP_FOLDER
mkdir -p $TMP_FOLDER
cd $TMP_FOLDER
git clone https://github.com/mkubecek/vmware-host-modules.git
cd $TMP_FOLDER/vmware-host-modules
git checkout $VMWARE_VERSION
git fetch
make
sudo make install
sudo rm /usr/lib/vmware/lib/libz.so.1/libz.so.1
sudo ln -s /lib/x86_64-linux-gnu/libz.so.1 
/usr/lib/vmware/lib/libz.so.1/libz.so.1
sudo /etc/init.d/vmware restart
| improve this answer | |
  • Fixed it for me on KUbuntu 19.04 – mephisto May 13 '19 at 19:04
  • Fixed it for me on Kubuntu 18.04 LTS. – Shai Sep 22 '19 at 19:00
  • This did not work for me in 19.04 with Workstation 15.5.0. The solution for me was to go into BIOS and disable secure boot. – darksky Sep 24 '19 at 5:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.