0

I am on ubuntu 19.04 codename disco dingo.

When I type this :

glxinfo | grep "OpenGL version"

I get this

OpenGL version string: 4.6.0 NVIDIA 418.56

same with binary driver :

$ glxinfo | grep "OpenGL version"
OpenGL version string: 4.4.0 NVIDIA 340.107

I hope I'm understanding correctly but I though mesa would come with ubuntu 19.04?

I also did the following :

sudo add-apt-repository ppa:ubuntu-x-swat/updates -y
sudo apt update
sudo apt full-upgrade -y

this did not help

How am I supposed to get mesa on ubuntu 19.04?

2

It looks like you're using the Nvidia 418.56 proprietary driver. Wikipedia states:

Proprietary graphics drivers (e.g. Nvidia GeForce driver and Catalyst) replace all of Mesa, providing their own implementation of a graphics API.

https://en.wikipedia.org/wiki/Mesa_(computer_graphics)

In other words, Mesa would be disabled by this driver.

  • @tatsu, try reading this answer again and the link provided. If you want to use mesa then remove the Nvidia drivers. This may provide a worse experience depending on your hardware (which isn't included in your question – doug Apr 21 at 2:06
  • with "Nouveau" I get : OpenGL version string: 4.3 (Compatibility Profile) Mesa 19.0.2. So the solution was installing the (previously stock) Nouveau driver as opposed to the (now stock) 418+ – tatsu Apr 21 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.