0

Problem: Forced to go through AT&T DNS. Tried many workarounds and unable to use preferred DNS, such as openDNS, Google, Commodo, etc.

I have UVERSE ATT Internet provider.You can use static DNS on Ubuntu or Windows, and adapter settings will show it looking fine, for example:

local machine DHCP: 172.16.1.105
              SM:   255.255.0.0
              GW:   172.16.0.150
              DNS1: 1.1.1.1
              DNS2: 1.0.0.1
         IP 6 DNS:2606:4700:4700::1111
              DNS:2606:4700:4700::1001

trace route from Windows or Ubuntu, first 2 hops are AT&T.

Windows, Adapter: DHCP IP address and Static DNS settings.

Tracert out-doesn't not go to Clouflare-1.1.1.1 to resolve.

The only way I get around their DNS, is using a dual core VPN, with tor running under the VPN.

Ive tried resolv.conf in 16.04 and NetworkPlan-->yaml in 19.04, with no success either.

@ vidarlo

dig google.com @8.8.8.8
;; connection timed out; no servers could be reached

With VPN connected: dig google.com @8.8.8.8
;; Query time: 1364 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sat Apr 20 19:31:11 EDT 2019
;; MSG SIZE  rcvd: 55
  • 1
    What are you asking about? Dual core vpn and tor? DNS? DNS settings? Remove everything that's unrelated to your question. To give you an answer, we have to understand what you try to achieve, and possible reasons for that failing. – vidarlo Apr 20 at 21:38
  • DNS servers cant be changed UVERSE ATT ISP_Tried with beaver and Disco – Jbizboca Apr 20 at 21:43
  • Can you try dig google.com @1.1.1.1 and dig google.com @8.8.8.8 in a terminal? You probably have to install dig first with sudo apt install dnsutils. Edit your question to include the output of the dig commands. – vidarlo Apr 20 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.