0

Just installed 18.04 on a Lenovo Carbon X1. It worked fine for a few days, but now when I boot and select Ubuntu 18.04 on the GRUB selection screen, the screen goes purple, then black. There's no Ubuntu (....) splash screen, but the desktop shows up for a split second before going to a black screen with a mouse pointer that I can move around.

When I go into recovery mode -> resume, everything seems to work fine but the resolution is different (onscreen text is smaller).

I can get into tty2 but running startx doesn't work.

I disabled Wayland via this. No change. Then I tried Step 1-2 of this. No change.

Here's my video card info:

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07) (prog-if 00 [VGA controller])
        Subsystem: Lenovo UHD Graphics 620
        Flags: bus master, fast devsel, latency 0, IRQ 255
        Memory at 2ffa000000 (64-bit, non-prefetchable) [size=16M]
        Memory at 2fa0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at e000 [disabled] [size=64]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [40] Vendor Specific Information: Len=0c <?>
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [ac] MSI: Enable- Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [100] Process Address Space ID (PASID)
        Capabilities: [200] Address Translation Service (ATS)
        Capabilities: [300] Page Request Interface (PRI)
        Kernel modules: i915
  • as an obvious, did you by chance install any new packages yet that may have interfered with ubuntu-desktop? (doubted, but figured i should ask.) – EarthToAccess Apr 20 '19 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.