1

When I suspend my PC and I try to wake it up again, the only thing I get is a blank black screen. I figured out that I can solve this problem by switching my graphic card from nvidia to intel. However I need the performances of the nvidia card, then I would like to find another way to solve it.

  • What laptop model, CPU and nVidia GPU do you have? – WinEunuuchs2Unix Apr 21 '19 at 15:39
0

For problems with 'Suspend'.

  • Add the repositories. Run in terminal:
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt update && sudo apt upgrade
  • Install the latest driver (preferably through the gui 'Additional drivers'). Run in terminal:
software-properties-gtk

and go to 'Additional drivers' tab and install the latest nvidia driver.

enter image description here

  • Install lightdm. Run in terminal:
sudo apt install lightdm
  • When asked asked to choose, choose lightdm.

  • If lightdm is already installed. Run in terminal:

sudo dpkg-reconfigure lightdm
  • When asked asked to choose, choose lightdm.
  • Reboot.
    This worked for me. Hope this works for you also.
  • Unfortunately, it didn't work... – holo gram Apr 20 '19 at 18:29
0

After installing nVidia proprietary drivers and running nvidia-settings check you have these similar files setup:

$ cat /etc/X11/xorg.conf

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0@0:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1@0:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection

Note: I may have hand crafted some of these entries but it was done so long ago I forget.

An additional, but probably unnecessary check is for this file:

$ cat /usr/share/X11/xorg.conf.d/50-nvidia-drm-outputclass.conf/nvidia-drm-outputclass.conf`

# This xorg.conf.d configuration snippet configures the X server to
# automatically load the nvidia X driver when it detects a device driven by the
# nvidia-drm.ko kernel module.  Please note that this only works on Linux kernels
# version 3.9 or higher with CONFIG_DRM enabled, and only if the nvidia-drm.ko
# kernel module is loaded before the X server is started.

Section "OutputClass"
    Identifier     "nvidia"
    MatchDriver    "nvidia-drm"
    Driver         "nvidia"
EndSection

If needing help using nvidia-settings, post comment below and I will dig up some google search links.

  • I've installed nvidia-drivers-418, but I can't find the xorg.config in /etc/X11. – holo gram Apr 21 '19 at 13:51
  • I've read problems with 418 over last few days. Personally I'm using 384 and it's been very stable. Either way you need to run nvidia-settings once and save the configuration, or see this Q&A for using nvidia-xconfig which might work better: askubuntu.com/questions/1023275/… There are many many questions in Ask Ubuntu with nVidia configuration questions that do not have answers. They date back to the year 2012 up to today. – WinEunuuchs2Unix Apr 21 '19 at 15:28
  • I managed to solve the problem by installing 396 nvidia driver. Indeed you were right, with the 418 there are some problems. – holo gram Apr 21 '19 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.