0

My dual monitors were working perfectly yesterday, but when I turned on my PC today, the monitors will only work when plugged into the motherboard to use the Intel integrated graphics.

I have the Nvidia X Server Settings (nvidia-driver-418) app downloaded (it was auto-detected and auto-installed). Any recommendations?

Note: this is occurring on Ubuntu 19.04.

EDIT: The GPU doesn't show up in Settings > Details > About. The only graphics listed is 'Intel HD Graphics 530 (Skylake GT2)'.

7
  • What does prime-select query return? Apr 19, 2019 at 20:14
  • I guess the bigger question is what changed between yesterday and today? Can you reboot and select "Advanced Options" on grub menu and select previous kernel? Does it work OK? Apr 19, 2019 at 20:22
  • 'prime-select query' returns 'nvidia'.
    – user945992
    Apr 21, 2019 at 22:04
  • Another user reported problems with 418 driver and using 396 driver solved the problem: askubuntu.com/questions/1135448/…. I'm using 384 driver with my GTX 970M and have never had a problem. Apr 21, 2019 at 22:19
  • How can I permanently change which driver it's using? In Software & Updates, each time I change it, select a new one, click Apply Changes, and restart, it goes back to 'Using X.Org X server'.
    – user945992
    Apr 22, 2019 at 0:11

1 Answer 1

0

Try this

$ sudo add-apt-repository ppa:graphics-drivers/ppa

$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001C03sv00001043sd000085ABbc03sc00i00
vendor   : NVIDIA Corporation
model    : GP106 [GeForce GTX 1060 6GB]
driver   : nvidia-driver-390 - distro non-free
driver   : nvidia-driver-396 - third-party free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

$ sudo ubuntu-drivers autoinstall

$ sudo apt install nvidia-396

$ reboot
3
  • All the commands worked, but the second. Doing the last command caused the machine to restart. Now, both screens work while connected to the GPU, but I can't login... When I enter the password, the screen goes black, and it starts again like if I haven't already entered the password.
    – user945992
    Apr 19, 2019 at 19:49
  • please try to make your /home/username folder empty Apr 21, 2019 at 8:49
  • I was able to login by: at the login screen, clicking Ctrl + Alt + F3, then typing in 'ls -lah', then 'sudo chown username:username .Xauthority'. Now the dual monitors don't work... only the one plugged into the motherboard...
    – user945992
    Apr 21, 2019 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy