1

I've bought Dell Vostro 14 5480 with preinstalled Ubuntu 14.04, reinstalled it to newer 18.10 and faced unpleasant issue - very low volume with bad quality on max settings. First time I see such thing on laptop with Linux and I'm very disappointed. If I plug in headphones - it is ok, good quality, good volume.

Here is alsamixer screenshot - seems that everything related is on max settings:

Alsamixer screenshot

4
  • This may sound stupid, but are you 100% sure that the issue just isnt poor quality speakers on the laptop? Have you hear them sound better on a different OS?
    – jwcooper
    Jul 16 '19 at 13:06
  • 1
    Can you try this first and then report back by leaving a comment @Fabby? 0:-) Спасибо.
    – Fabby
    Jul 18 '19 at 22:22
  • @Fabby, thank you very much for this link! It helped me! Two years I've tried to find solution to this problem and now it's done! No one could even realize how I'm happy! Post answer with this link and I'll approve it. Jul 19 '19 at 17:23
  • Пожалуйста! ;-)
    – Fabby
    Jul 19 '19 at 19:57
3
+50

You're not going to like this as the workaround below allows you to get good sound from your speakers by allowing the subwoofer, but will disable your headphones:

:-(

  1. Install alsa tools:

    sudo apt-get install alsa-tools alsa-tools-gui
    
  2. Open a terminal by pressing Ctrl+Alt+T and type:

    hdajackretask
    
  3. In the window that opens, select the codec Realtek ALC290

  4. On the left side of the window find Headphone, Left side
  5. Check Override
  6. Select Internal speaker(LFE)
  7. Stop PulseAudio because if don't, applying settings will fail because of device busy (at least it is so for 19.04)

    systemctl --user stop pulseaudio.socket
    systemctl --user stop pulseaudio.service
    
  8. Click Apply now

  9. Start PulseAudio again

    systemctl --user start pulseaudio.socket
    systemctl --user start pulseaudio.service`
    
  10. Test your sound.
  11. If all is well, press Install boot override
  12. reboot your system.

If you want to get headphones back, go back to step 2 and:

  • Uncheck Override in step 5

    or

  • Click Remove boot override.

Source

5
  • One addition - to apply these changes PulseAudio should be stopped (systemctl --user stop pulseaudio.socket and systemctl --user stop pulseaudio.service) and then after applying started again. If don't do it, hdajackretask will complain on busy device. At least it is so for 19.04. Jul 19 '19 at 19:05
  • 1
    Dmitry Please feel free to edit my answer and put that step right where it belongs...
    – Fabby
    Jul 19 '19 at 19:59
  • 2
    +1 for all the <kbd> </kbd> work :) Jul 19 '19 at 23:54
  • @Fabby, done, answer edited Aug 7 '19 at 10:44
  • 1
    @DmitriyVinokurov Thank you! Edit approved (so that gave you some additional rep) and then re-edited to allow for better readability. And look: You're a 100 rep user again already!
    – Fabby
    Aug 7 '19 at 11:14
0

If you are using the Intel audio SOF driver then you cannot use the hdajackretask to tune pins in order to increase the volume. (hdajackretask works only with legacy intel audio driver).

So, for the Intel audio SOF driver: Just start "alsamixer" with sudo and you'll see much more volume controls comparing to what you can see if you run it under the non-root user. Increase the volume of (most of) these levels like Headphone, Speaker, PGA, and the speakers' volume should become louder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.