10

I used the built-in upgrader to upgrade to 19.04 today, and I'm now stuck in a login loop. I have tried many solutions from forums, but nothing has worked. Is there something I'm missing or anything else I should try?

From what I've seen, I don't think that there is an Xauthority file on my computer. I'm on a Dell XPS 15 with a GTX 1050Ti Max-Q GPU, and a Core i7 processor. I also have a Windows dual boot, and while Ubuntu's my main OS, luckily almost everything is on GitHub, Google Drive or my Windows partition.

Results of ubuntu-drivers devices :

emil@emil-XPS-15-9570:~$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001C8Csv00001028sd0000087Cbc03sc02i00
vendor   : NVIDIA Corporation
model    : GP107M [GeForce GTX 1050 Ti Mobile]
driver   : nvidia-driver-418 - distro non-free recommended
driver   : nvidia-driver-415 - third-party free
driver   : nvidia-driver-396 - third-party free
driver   : nvidia-driver-390 - distro non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

Results of sudo systemctl start graphical.target :

Failed to start graphical-target.service: Unit graphical-target.service not found.
10

I had to disable the Extensions Gnome extension.

  1. Being at Login screen go to the second terminal (CTRL+ALT+F2)
  2. Login as your user there
  3. Execute gnome-shell-extension-tool -d extensions@abteil.org
  4. Restart the system or go back to the first terminal (CTRL+ALT+F1) with GUI Login screen and try to login again.

Please look at /var/log/syslog and check if you see some Gnome crash stacktrace.

|improve this answer|||||
  • I had to create the new user from tty and add new user to sudoers. after that i just renamed the .config in my original user's home directory and it started working. Be aware that you will lose the customization you had done. – Saurabh Apr 20 '19 at 6:27
  • You nailed it, Milso! – Cranky Apr 21 '19 at 22:51
  • 1
    This solution assumes the user can log-in under a new name. But what if log-in is impossible for any name? This is the problem I had. The only solution I could think of was a fresh install, onto a fresh-formatted partition, and choosing the "minimal" install option. I am slowly adding all the apps that ran in 18.10. After 2 days, no problems yet. My thanks to Milso for providing a direction. – rob grune Apr 22 '19 at 1:46
  • @robgrune Please check the edited post. You can easily log in as your own user with no graphical environment just switching the terminal. – Milso Apr 22 '19 at 6:31
  • 1
    @Milso. Please, could you help? It has re-occurred; no login possible. I followed your approach to switch and delete the extension. The message is:... extension is not found or not installed. I switched back to graphic screen logon. The logon screen shows my user name, but when I enter the pwrd, the screen loops back. Impossible to logon. I am using the exact same apps in 19.04 as used in 18.10, so I cannot understand why an app would be causing this. Thank you. – rob grune Apr 22 '19 at 10:41
4

(As @robgrune said in comments, 19.04 seems to be particularly susceptible to extensions, and @Milso's answer is on the right track, but in my case creating a new user didn't fix the problem.)

If you create a new user and still can't log in, then it's possible that a gnome extension package is causing your problem.

In my case, I had to uninstall gnome-clocks.

sudo apt remove gnome-clocks

There are also other packages that are actually gnome extensions but, unfortunately, not all are listed as extensions. To see all the gnome packages chosen:

sudo apt list --installed | grep gnome | grep -v automatic

Then uninstall one-by-one until you can log in again. You can always reinstall them again afterwards.

|improve this answer|||||
  • It was gnome-clocks !!! – Michael May 29 '19 at 22:45
  • It was gnome-clocks (the version 3.32.0-1 that you can install with sudo apt-get install gnome-clocks) for me as well, on Ubuntu 19.04. Actually, I found two workarounds: 1) install the snap version of gnome-clocks from here; 2) install gnome-clocks via apt-get but uninstall the extension Clock Override. – Giulio Guerrieri Jul 24 '19 at 14:27
2

One possible cause for a login loop is installation of chrome remote desktop in ubuntu 19. Remove it via the terminal, and login works again.

sudo apt remove chrome-remote-desktop
|improve this answer|||||
  • This solution worked for me! – user1754322 2 days ago

Not the answer you're looking for? Browse other questions tagged or ask your own question.