5

Is there a way to solve this?

$ /usr/local/pulse/pulseUi
/usr/local/pulse/pulseUi: error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory
  • It sounds as though you updated from an earlier version of Ubuntu? What application are you trying to run. – Charles Green Apr 18 at 21:08
  • right I upgraded from 18.10 trying to run Pulse Secure a VPN client – bartvde Apr 18 at 21:09
  • From their website, they don't officially support anything over 18.04, however I did see a tech note there indicating that there was a way to run it on 18.10. You may need to contact them for support https://www-prev.pulsesecure.net/download/techpubs/current/1383/pulse-client/pulse-secure-client-desktop/9.0rx/ps-pulse-9.0r2-supportedplatforms.pdf – Charles Green Apr 18 at 21:14
  • 1
    Try this wget http://mirrors.edge.kernel.org/ubuntu/pool/universe/w/webkitgtk/libwebkitgtk-1.0-0_2.4.11-4_amd64.deb; sudo dpkg -i libwebkitgtk-1.0-0_2.4.11-4_amd64.deb; sudo apt install -f. – Kulfy Apr 18 at 21:14
  • Thanks I then get: dpkg: dependency problems prevent configuration of libwebkitgtk-1.0-0:amd64: libwebkitgtk-1.0-0:amd64 depends on libjavascriptcoregtk-1.0-0 (= 2.4.11-4); however: Package libjavascriptcoregtk-1.0-0 is not installed. libwebkitgtk-1.0-0:amd64 depends on libicu60 (>= 60.1-1~); however: Package libicu60 is not installed. – bartvde Apr 18 at 21:20
11

Ubuntu 19.04 is not support platform for pulse secure. You may get it work by following below instructions without installing dependencies by package manager. Note: Use carefully && caution with your own risk.

  • As root user, run:

    dpkg -i pulse-9.0.R3.x86_64.deb
    cd /usr/local/pulse/
    
  • Allow installation for 19.04 by sed ( or manually in line 279 in PulseClient_x86_64.sh)

    sed -i "s/UBUNTU_VER\ \=\ 18\ \]/& \|\|\ [\ \$UBUNTU_VER\ \=\ 19 \]/" PulseClient_x86_64.sh
    
  • May not needed. At least it will fail with packages which not found.

    ./PulseClient_x86_64.sh install_dependency_packages
    
  • Lets make debs and extra folders:

    mkdir /usr/local/pulse/extra
    mkdir /usr/local/pulse/debs   
    
  • Download below packages from archice.ubuntu.com to /usr/local/pulse/debs:

    cd /usr/local/pulse/debs
    wget http://archive.ubuntu.com/ubuntu/pool/main/i/icu/libicu60_60.2-3ubuntu3_amd64.deb
    wget http://archive.ubuntu.com/ubuntu/pool/universe/w/webkitgtk/libjavascriptcoregtk-1.0-0_2.4.11-4_amd64.deb
    wget http://archive.ubuntu.com/ubuntu/pool/universe/w/webkitgtk/libwebkitgtk-1.0-0_2.4.11-4_amd64.deb
    
  • Extract *.deb files on /usr/local/pulse/extra

    cd /usr/local/pulse/extra
    dpkg -x /usr/local/pulse/debs/libicu60_60.2-3ubuntu3_amd64.deb .
    dpkg -x /usr/local/pulse/debs/libjavascriptcoregtk-1.0-0_2.4.11-4_amd64.deb .
    dpkg -x /usr/local/pulse/debs/libwebkitgtk-1.0-0_2.4.11-4_amd64.deb .
    
  • Which to normal user and export LD_LIBRARY_PATH in command line:

    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/pulse/extra/usr/lib/x86_64-linux-gnu/
    
  • As normal user, run pulse secure GUI on command line:

    /usr/local/pulse/pulseUi
    

Now you should able to see pulseUI and continue with it. Note: For troubleshooting purpose, you can use ldd command to check which libraries are needed, like: ldd /usr/local/pulse/pulseUi

  • Note, if your IT department provided an older version of the Pulse client, you may need the i386 versions of packages mentioned here. Just substitute i386 instead of amd64 in all the URLs and commands listed here. Worked for me with version 5.3r2.0-b853 . – aap May 14 at 0:34
  • 2
    This worked like gold at my end, huge thanks! – Jakub Strebeyko May 27 at 9:26
  • Didn't work for me after copying and pasting each line, line-by-line. Still getting : error while loading shared libraries: libwebkitgtk-1.0.so.0: cannot open shared object file: No such file or directory – EoRaptor013 Jun 6 at 2:08
  • 1
    I had to hand edit the PulseClient_x86_64.sh file to include v 19. If anyone is interested, I can upload the file with its edits. – EoRaptor013 Jun 6 at 2:49
  • Worked for me as well. Thanks. – Subin Sebastian Nov 13 at 6:00
1

Please forgive the fact that this is an answer and not a comment. I signed up just to help out on this problem. To piggyback off what @jacke posted above. Follow his guide first!

If you notice that your Pulse Icon no longer works from the launcher do the following:

$ sudo nano /usr/share/applications/pulseUi.desktop

Edit the Exec line to

Exec=/usr/bin/env LD_LIBRARY_PATH=/usr/local/pulse/extra/usr/lib/x86_64-linux-gnu:$LD_LIBRARY_PATH /usr/local/pulse/pulseUi
1

If you want to use Pulse Secure only as a client to connect to a VPN, you can use open connect. Here I go into detail, step by step.

  1. Install the package

    sudo apt-get update
    sudo apt-get install openconnect
    
  2. Install certificates

    sudo apt-get install ca-certificates
    sudo update-ca-certificates
    
  3. Connect

    sudo openconnect --protocol = nc vpn.example.com
    

References:

http://www.yorku.ca/computing/download/ps-pulse-9.0r1-linux-quickstart-guide.pdf https://websiteforstudents.com/install-openconnect-ssl-vpn-client-on-ubuntu-18-04-18-04/

0

For me it was as simple as installing the Pulse deb then running:

sudo /usr/local/pulse/PulseClient_x86_64.sh install_dependency_packages
sudo apt install libwebkitgtk-1.0-0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.