7

I have high cpu use in Ubuntu 19.04, and my screen seems laggy.

Watching top I see gnome-shell running about 50% very often.

  • 1
    I'm having the same problem even when I deactivate all the extensions ... this is particularly annoying as I'm on a laptop and it makes the fans spin up all the time and reduces baterry lmife ... – Dennis de Best May 29 '19 at 12:34
6

The new version of gnome-shell is not compatible with some extensions. In particular those trying to show systray, such as "TopIcons Plus" are not working well.

Disable extensions (one-by-one?) to see if this reduces CPU usage.

To do this, install the gnome-tweaks package.

Open tweaks, check the extensions tab on the left, and disable extensions on the right (shown below, POP_OS, but should be similar/identical in other flavors of Ubuntu):

Screenshot of gnome-shell application showing disabled topicons plus extension

An alternative to TopIcons Plus which seems to catch most of the systray devices is "KStatusNotifierItem/AppIndicator Support"

  • 1
    Wow! I can toggle TopIcons on and off and watch gnome-shell CPU use go from ~10% of a core to 99%. – PatKilg May 30 '19 at 16:23
  • @ZachBloomquist You will notice here that users of 'TopIcons Redux' are in fact suffering from this bug, on Gnome shell 3.32 – Charles Green May 31 '19 at 16:23
  • @ZachBloomquist It will be great if 3.32.1 has fixed the issue - the version of gnome shell in the Ubuntu repositories is still 3.32.0 – Charles Green May 31 '19 at 16:29
  • @CharlesGreen you're right, it's still broken, the issue has returned after sleeping/waking the computer – Zach Bloomquist May 31 '19 at 17:55
  • 1
    Just checking back in, 3.32.2 does seem to fix the issue and it's available from apt. – Zach Bloomquist Jul 8 '19 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.