25

I'm running Ubuntu Desktop 18.04/20.04 LTS as a guest in Virtualbox on a Windows 10 host with multiple physical screens connected to the host. Every time I boot the Ubuntu VM it comes to a black screen, i.e. no feedback. However, if I type the password and press Enter it logs in and shows the Desktop as normal. I suspect it might be a graphics issue.

Any idea what to do?

55

So as i've suspected that it's a graphics issue, I went into the settings, first thinking it's a drivers issue, since many other posters of slightly different questions have had solutions with changing the drivers/controllers (or even CPU architecture etc). The other thought I had that might be the problem is that i'm running multiple screens on the host. Perhaps the guest VM is struggling to connect with them.

What worked for me was to:

  • Shutdown the VM
  • Go to the specific VM settings
  • Go to the Display Tab
  • Under the Screen Tab I increased my Monitor Count (which then indicated an error that the "settings are invalid"), which made me think of tinkering with the Video Memory.
  • So I increased the Video Memory to 64MB (it was 16MB initially)
  • Booted up the VM ... and hey presto it worked ... now i see my login screen
| improve this answer | |
  • 1
    Thanks. I solved my issue with exactly your steps. My host machine is Win10. It has 2 screens. – smwikipedia May 18 '19 at 7:41
  • 1
    Works for 20.04 too. – Martin May 15 at 0:51
  • 2
    So I increased the Video Memory to 64MB (it was 16MB initially) - this is it, my virtual box instance turned back (video driver crashed) when I went into full screen mode. Increasing the video memory did the trick! – matrixanomaly May 23 at 5:42
  • Interestingly, the black screen started occurring for me after I installed, updated Ubuntu to latest stuff, ran the "Guest Additions CD Image", and rebooted.... Increasing the video memory also fixed things for me! – Jeroen Oct 13 at 20:37
5

I did what they said there: Black screen in Ubuntu in Virtual Box "I changed the graphics controller to VBoxVGA"

And it worked for me. My host machine is Windows 10 and it has 2 screens

| improve this answer | |
1

I encountered the same error with the version of VirtualBox from Ubuntu's official repositories. Increasing video memory fixed the problem as reported.

However, installing VirtualBox 6.1 per the instructions on Oracle's website allowed me to run Ubuntu without increasing video memory.

Either way works fine, but newer software is nice.

| improve this answer | |
0

With VBox 6.0 and Ubuntu 18.04 neither worked for me.

Switching to VMSVGA fixed the display.

| improve this answer | |
0

I tried upping available video memory and changing the display adapter type with no luck. I had a hunch it may be related to VirtualBox Guest Additions. Uninstalling them did it for me.

  • Change into /opt/VBoxGuestAdditions-<version_number> folder

        cd /opt/VBoxGuestAdditions-<version_number>
    
  • In there run:

        sudo ./uninstall.sh    
    
| improve this answer | |
0

I tried all previous answers with no luck.

But, inserting CD VBoxGuestAdditions and install it (a recent version) worked

| improve this answer | |
  • Can't be a solution. The OP mentioned, that he used multiple monitors in a VM. Only possible if he has installed the guest additions. See here how to answer a question. If you want to comment (which your answer is), wait until you have enough reputation – kanehekili Jul 4 at 21:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.