I want to increase the resolution of my Acer Aspire One D250-1326 which has Ubuntu 11.10 installed. The native resolution is 1024x600 and I want to increase it to 1440x810 or 135%. I've tried two methods that both use xrandr...creating a new resolution mode and applying it to my display, and scaling the display.

This picture shows the commands I entered into the terminal to create a new resolution mode:

enter image description here

  1. Enter "xrandr -q" to show that the current resolution is 1024x600.

  2. Enter "cvt 1440 810 60" to find the modeline for a resolution of 1440x810 at 60Hz.

  3. Enter "xrandr --newmode..." to create the custom mode.

  4. Enter "xrandr --addmode LVDS1..." to apply the mode to my netbook display. Here is where I experience the "BadMatch" error. Note: When I enter "xrandr --addmode VGA1..." instead, the mode is successfully applied to the VGA1 display.

The second method I attempted is scaling the display. I had success using this method when I used Ubuntu 11.04. Now for some reason, when I use the same scaling command, my mouse becomes constrained to the top-left portion of the screen. Here are the steps I took:

enter image description here

  1. Enter "xrandr -q" to show the current state of the display. Note: You can see the mode I created during the previous method. Again, I was not able to apply it to the LVDS1 display, but I could apply it to VGA1.

  2. Enter "xrandr --output LVDS1 --scale 1.35x1.35" to scale the display. After this is done, the resolution is changed but the mouse cannot move any lower than you see here in the picture.

I also tried using different panning options without any success. One route I did see is to revert a patch which is said to solve the scaling problem. I have not been able to figure out how to perform this action though. Here is a link, with the confirmation near the bottom: BUGS(dot)freedesktop.org/show_bug.cgi?id=39949 (Dang spam prevention, can't post >2 links)

I would appreciate your help solving this problem. Otherwise I guess I'll just go back to 11.04. Thanks

2 Answers 2


I Also have a Netbook with a native 1024x600 resolution which is too small sometimes. I struggled hard with xrandr and searched a lot in www and so on. Finally, I got a Solution which works for my EeePc. I Use a trick: I configure a not-connected VGA-Output, that helped increase the resolution without the mouse been catched. This Example shows a scaling by 1.5:

xrandr --newmode "1536x900" 113.75 1536 1624 1784 2032 900 903 913 934 -hsync +vsync xrandr --addmode VGA1 1536x900 xrandr --output VGA1 --mode 1536x900 --output LVDS1 --fb 1536x900 --scale 1.5x1.5

I hope it works for you too !


xrandr --newmode "1536x900" 113.75  1536 1624 1784 2032  900 903 913 934 -hsync +vsync
xrandr --addmode VGA1 1536x900
xrandr --output VGA1 --mode 1536x900 --output LVDS1 --fb 1536x900 --scale 1.5x1.5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.