4

I know this question has been asked (and answered) multiple times, but I've tried all of the "solutions" suggested elsewhere, and none of them work. Steam is the only app that I can't get working.

$ steam 
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2019-04-17 13:41:28] Startup - updater built Nov 23 2016 01:05:42
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

I have the NVidia 410 drivers installed. Does anyone have any other ideas? I've tried the following:

  1. Removed ~/.steam and ~/.local/share/Steam/
  2. Removing and installing Steam from both Ubuntu and steampowered.com
  3. Installing all sorts of i386 packages
  4. The instructions on this page: https://linuxconfig.org/how-to-install-steam-on-ubuntu-18-04-bionic-beaver-linux
7
+100

I have had a similar issue (not identical though). I had to remove both steam and my Nvidia drivers. Rebooted.

I then reinstalled my Nvidia drivers with sudo ubuntu-drivers autoinstall, rebooted, and then installed Steam.

|improve this answer|||||
  • 1
    Thanks, that worked! I did "sudo add-apt-repository ppa:graphics-drivers/ppa; sudo apt remove nvidia-*" to remove the driver, then "sudo apt install nvidia-driver-418" to install it (which updated me to the 418 driver). – lord_nimon Apr 17 '19 at 20:18
  • Drop by in chat sometime and leave a message @Fabby – Fabby May 8 '19 at 6:55
  • I did the same as @lord_nimon - except using 'nvidia-driver-440'. This reinstalls everything that I unstalled - which is everything with nvidia*440: – Carlo Wood Jan 16 at 18:25
  • The following packages will be REMOVED: cuda-drivers* cuda-runtime-10-0* libnvidia-cfg1-440* libnvidia-common-440* libnvidia-decode-440* libnvidia-encode-440* libnvidia-fbc1-440* libnvidia-gl-440* libnvidia-ifr1-440* nvidia-compute-utils-440* nvidia-dkms-440* nvidia-driver-440* nvidia-kernel-common-440* nvidia-kernel-source-440* nvidia-utils-440* xserver-xorg-video-nvidia-440* - except cuda-drivers* cuda-runtime-10-0*` which I did not reinstall yet. After that reinstalled steam and everything worked. – Carlo Wood Jan 16 at 18:25
  • I believe that the main issue is that when reinstalling it ALSO installed perviously uninstalled i386 packages though: libnvidia-compute-440:i386 libnvidia-decode-440:i386 libnvidia-encode-440:i386 libnvidia-fbc1-440:i386 libnvidia-gl-440:i386 libnvidia-ifr1-440:i386 – Carlo Wood Jan 16 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.