3

I've been trying to install Kubuntu 18.04 and I keep running into the same problem of the installer getting to the point where it needs to install grub and fails with the message:

Can't install grub on sda

After many hours of troubleshooting, I realized that I can get it to install if I reinstall Windows in non-EFI mode, however, this was causing some weird problems with my motherboard so it's no longer an option. I came to this conclusion via checking Disk Management on Windows. As seen in this image...

Disk Management

there is an efi partition. Whenever Kubuntu would install, there wouldn't be an efi partition. So I'm assuming my current Windows install is an UEFI based one. Also, when Windows is installed in UEFI mode, Disk Management initializes the other drives as GPT instead of MBR.

So my question would be what do I need to do (if it's possible) to install Kubuntu while keeping windows in UEFI mode?

Let me know if there is any more information that you need.

2
  • 1
    For better results disable any CSM/Legacy in UEFI settings. This assures you'll be booting and consequently installing in the correct UEFI mode.
    – user880592
    Commented Apr 17, 2019 at 14:48
  • Thanks, I have seen the UEFI USB option in the boot menu, so I will give that a try.
    – Ledus
    Commented Apr 17, 2019 at 16:37

1 Answer 1

4

Boot Live USB in UEFI Mode

Update for Ubuntu 22.04

The initial boot process of booting from the Ubuntu installation USB in BIOS and UEFI modes have changed. You will get very similar inital GRUB screens irrespective of which mode you boot your LiveUSB.

If you boot from the LiveUSB of Ubuntu 22.04 in UEFI mode you will get:

enter image description here

Note the last item in the Grub Menu, UEFI Firmware Settings.

On the other hand if you boot from the LiveUSB of Ubuntu 22.04 in BIOS mode you will get:

enter image description here

Note there is No UEFI Firmware Settings in the Grub menu

Original Answer

If you install Windows in UEFI mode, you will have to install Kubuntu also in UEFI mode.

You should select the boot from "UEFI something USB" or "USB something UEFI" when you boot from the Live USB to install Kubuntu.

If you boot from the LiveUSB in the UEFI mode you will see this screen:

enter image description here

On the other hand if you boot from the USB in the BIOS/Legacy mode you will see:

enter image description here

Immediately followed by:

enter image description here

See for more details https://help.ubuntu.com/community/UEFI

Also make sure Fast Boot is disabled in Windows.

3
  • Thank you, I was able to get it to work and now have access to both Ubuntu and Windows boot manager in grub, with not weird glitches of any kind.
    – Ledus
    Commented Apr 18, 2019 at 15:23
  • My Windows is installed in UEFI mode, and when I run the Ubuntu installer I see the UEFI firmware settings option you describe. But in the choose disk screen, Ubuntu still can't see my Windows OS (and it's not encrypted). What else can I check please?
    – Richard
    Commented Jun 13, 2023 at 9:17
  • @Richard please ask a new question with a link to this one as reference. Two things came to my mind: 1. Bitlocker. 2. Dynamic Windows partitions. Check neither of these are not there.
    – user68186
    Commented Jun 13, 2023 at 13:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .