Ubuntu 18.10, Firefox 66.03

Videos in the browser (youtube, twitter, reddit) load, and then pause. I can see any moment of the video as a still, but I can not play the video.

Does anyone know a fix for this? I have tried installing flash, installing ubuntu restricted extras, gstreamer, and so far the behavior persists.

edit: hardware... also disabling hardware accelleration in firefox does not solve anything. Currious why Virtualbox is reporting as VmWare.

$ lspci -vnn | grep VGA -A 12  
00:02.0 VGA compatible controller [0300]: VMware SVGA II Adapter [15ad:0405] (prog-if 00 [VGA controller])
    Subsystem: VMware SVGA II Adapter [15ad:0405]
    Flags: bus master, fast devsel, latency 64, IRQ 18
    I/O ports at d010 [size=16]
    Memory at f0000000 (32-bit, non-prefetchable) [size=128M]
    Memory at f8000000 (32-bit, non-prefetchable) [size=2M]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Kernel driver in use: vmwgfx
    Kernel modules: vmwgfx

00:03.0 Ethernet controller [0200]: Intel Corporation 82540EM Gigabit Ethernet Controller [8086:100e] (rev 02)
    Subsystem: Intel Corporation PRO/1000 MT Desktop Adapter [8086:001e]
    Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 19
    Memory at f8200000 (32-bit, non-prefetchable) [size=128K]
  • 2
    Please edit and post hardware (graphics) information and drivers version if you installed any. That's where troubleshooting should start. The things you say you did have zero impact on the rpoblem (YouTube no longer uses flash and additional codecs aren't required either).
    – user880592
    Apr 17 '19 at 14:10
  • You're running Ubuntu as a Virtual Machine!!! But you conveniently omitted that info. No, in a VM all bets are off. The virtual GPU is probably not enough.
    – user880592
    Apr 17 '19 at 14:56
  • @GabrielaGarcia Seems simple enough to play a video in a web browser, not sure why "all bets are off" just because of virtualization. Yes there is an added layer of complexity, but it doesn't mean things can't or shouldn't work. I have had this working on older VMs.
    – DSn0wMan
    Apr 17 '19 at 15:36
  • This seems to be a bug with VirtualBox, as per OP's self-answer.
    – pomsky
    Apr 19 '19 at 16:59

Updating VirtualBox and VirtualBox Guest Additions from 6.04 to 6.06 fixed the issue.

Edit: It appears the issue is not fixed. The video freezing seems to happen after locking the host and logging back in, so it's likely a VirtualBox bug/issue and not anything to do with Ubuntu or Firefox

  • In that case consider reporting the issue to VirtualBox developers.
    – pomsky
    Apr 19 '19 at 15:08

The only workaround I found so far was to disable audio in the settings of the virtual machine.


It works (at least for youtube), by setting, in the audio page: the host driver to Pulse Audio and the guest controller to ICH AC97. The video was left unchanged (host set to VMSVGA with 3D acceleration on and Firefox in the guest with hardware accel on).

The host is slackware64 14.2 (with KDE1.1) and the guest is slackware-current64 (with xfce4), both using pulseaudio Virtualbox version is 6.1.6

  • 2
    Are you sure settings on slackware apply to Ubuntu? Feb 17 at 9:44

I also faced this problem. then i just increased the video memory from 16mb to 32mb of debian vm. it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.