9

I'm running Ubuntu Mate 18.04 (32 bit) and I'm having trouble pairing a bluetooth speaker. It has worked before, but after putting the system to sleep and using the speaker with another computer it never seems to want to pair again.

Meanwhile, other computers can pair with and use the speaker with no problems.

  • I tried pairing it manually with bluetoothctl but I always get a Failed to pair: org.bluez.Error.AlreadyExists. I can't say I know what that means.

  • I can successfully remove the device, but the result is always the same when trying to pair it again.

  • The device is not listed when doing paired-devices.

  • As suggested in other answers I tried restarting pulse audio with pulseaudio --kill and pulseaudio --start, and tried pairing again. No difference.

How do I find out what's wrong?

2
  • I'd make sure that the speakers don't pair with the other computer (maybe you've already checked that) by watching the output bluetoothctl on the other computer. May 23, 2020 at 15:38
  • My best guess is that the drivers aren't good enough to restore the adapter after suspend (a hard problem). At least that's the case for the Ethernet drivers, which I have systemd restart for me after every resume from suspend. Restarting the machine whenever the problem occurs without touching the speaker will show whether this is the case for Bluetooth as well.
    – Andreas
    Aug 19, 2020 at 16:13

4 Answers 4

3

What helped me was to restart the Bluetooth service.

When I did sudo service bluetooth status I saw error info in red:

Unable pair since another pairing is in progress

and another one

B4:6C:47:53:FF:86: error updating services: Device or resource busy (16)

So I did sudo service bluetooth restart and then I was able to pair the device.

2
  • 1
    I've been using a oneshot service that does /etc/init.d/bluetooth restart after suspend.target, so basically the same thing, I think. I assume you're also mainly having the problem after waking from suspend and not immediately after boot?
    – Andreas
    Feb 2, 2021 at 19:15
  • Yes, but only with my new Panasonic headphones and not always. Happened 2 times till now.
    – Zbyszek
    Feb 3, 2021 at 18:20
1

That's what I found

systemctl start bluetooth
bluetoothctl
power on
agent on
scan on
pair XX:XX:XX:XX:XX:XX
connect XX:XX:XX:XX:XX:XX
0

Add the device to be connected to the trusted list by using trust 00:00:00:00:00:00 and then try to connect or pair.

2
  • 5
    did that but still getting Failed to pair: org.bluez.Error.AlreadyExists
    – pevinkinel
    Aug 18, 2020 at 17:52
  • I am stuck on AlreadyExists. The Raspberry Pi thinks there's already a pair, but the target tablet removed the pair. I can't figure out how to reestablish the pair without opening up the Raspberry Pi. If you do this experiment with a cheap Bluetooth speaker the pair comes right back
    – Phlip
    Nov 14, 2022 at 19:55
0

for me it was needed to just run:

bluetoothctl connect <MAC-ADRESS>

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .