We have tried to install mini.iso for ubuntu 16.04 which fails to complete installation.

While installing libc6-udeb, it failed for unknown reasons.

It says "An installation step failed. you can try to run the failing item The failing step is: Detect disks."

Failed to load installer component.
Loading libc6-udeb failed for unknown reasons. Aborting

Kindly advise how to install. If you need more information, please ask.

2 Answers 2


Are you using the most up to date installer?
There is an incompatibility with the original installer and package updates (including libc6-udeb) that are downloaded in during the install process.

I have been having the same issue with a PXE installer that I use for unattended installs, after updating the netboot image & installer, the issue went away and I was able to successfully install 16.04 😀

The most recent version, which worked for me, is available here - http://archive.ubuntu.com/ubuntu/dists/xenial-updates/main/installer-amd64/current/images/netboot/

Thanks to Alex Brett at Citrix for the tip off on the Debain mailing list - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833706#45


It was reported as a bug:


In the comments, I found a build that shouldn't have that issue, but I didn't try it:


I decided to switch to the 18.04 version, and I don't have that issue anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.