1

I recently bought a HP-BW088AX Laptop from Amazon. I initially installed Kali Linux on it because I wanted to learn penetration testing and hacking, but as I was new to Linux I decided to go for a more user-friendly distro. So I dual booted my laptop with Ubuntu.

After I installed Ubuntu I had to face some issues with the inbuilt wireless card. I had faced similar issues with Kali Linux but I got them solved.

The problem was that the OS wasn't detecting the inbuilt wireless card which is a Realtek RTL8723DE chipset. I installed the drivers for it from here RTL8723DE Drivers, consequently the wireless card was detected but the signal was very weak. So I started finding a solution on the internet and I found this : Weak Wi-Fi Signal in Ubuntu

Output of lspci:

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device d723

This solution worked for Kali Linux which is also a debian based distro but the same is not working for Ubuntu. But it is not working in Ubuntu. Everything works fine until I run this command :

sudo modprobe -rv rtl8723de ant_sel=2

I get the following output :

modprobe: FATAL: Module ant_sel=2 not found.

I didn't face this issue in Kali Linux.

  • I have Ubuntu 18.04.02 LTS.
  • Processor : AMD® A9-9420 radeon r5, 5 compute cores 2c+3g × 2
  • Graphics : AMD® Stoney
  • GNOME : 3.28.2

Any help would be appreciated a lot. Thanks in advance.

1

The drivers for RTL8723DE were released recently on github. Visit this link and : RTL8723DE drivers

and clone the folder.

Follow the instructions using root privilages:

git clone https://github.com/smlinux/rtl8723de.git -b 4.15-up
dkms add ./rtl8723de
dkms install rtl8723de/5.1.1.8_21285.20171026_COEX20170111-1414
depmod -a
reboot
|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.