2

I'm unable to turn off backlight of my keyboard. I've tried every solutions available on the internet including xset, etc. But nothing seem to work on AsusFX503. I've Ubuntu 18.04 installed. Please help.

  • 2
    Try echo 0 | sudo tee /sys/class/leds/asus::kbd_backlight/brightness – Kulfy Apr 15 '19 at 20:29
  • tee: '/sys/class/leds/asus::kbd_backlight/brightness': No such file or directory 0 – Nitesh Tosniwal Apr 19 '19 at 10:52
  • 1
    What is the output of ls -l /sys/class/leds/? – Kulfy Apr 19 '19 at 18:21
  • @Kulfy sorry for late reply. output – Nitesh Tosniwal Apr 26 '19 at 12:06
  • And what about ls -l /sys/devices/platform? – Kulfy Apr 26 '19 at 12:47
1

It was fixed in kernel 5.0, check xev and try to press this combos.

| improve this answer | |
  • nothing happening. The data updates but not when I press "fn + arrow_down", which is how keyboard backlight can be changed. Thank You.. – Nitesh Tosniwal Sep 6 '19 at 20:05
  • 1
    What kernel version do you have? Run uname -a, and what kind of data are you talking about? Since kernel 5.0+ fn+arrow combos should map to XF86KbdBrightnessUp and down – V. Dalechyn Sep 6 '19 at 23:18
  • 1
    Yea! Thanks. I upgraded to kernel 5 from 4. It solved the issue. – Nitesh Tosniwal Dec 7 '19 at 8:00
1

I found the rogauracore package on Github here: https://github.com/wroberts/rogauracore. On my G531GT it allowed me to control the color of the backlight, which included turning it off. I can't easily dim the backlight, but I can choose a color which is less bright, effectively dimming it, although not as convenient.

It's not the real solution to the problem (which probably involves some kernel update), but a very useful workaround with the added bonus that you can actually control the RGB on the backlight too.

| improve this answer | |
  • Unfortunately it didn't work from me. which colour did you use? I've red backlight, tried some dim hex values but didn't work :). – Nitesh Tosniwal Jul 26 '19 at 9:52
  • Does rogauracore black work for you? My keyboard is RGB so it makes a bit more sense to control the color. Sorry if it didn't work for you :( – mkreisel Jul 26 '19 at 13:06
  • Worked for me. Thanks – code13 Jan 18 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.