0

Cannot install Nvidia driver for RTX 2080 Ti in Ubuntu 18.04 LTS !!!!

I am trying to install nvidia driver with RTX 2080 Ti in Ubuntu 18.04 LTS

After Installing nvidia-driver (version 418.57) , the system will not boot . The following output comes and the screen stays blinking :

[code]/dev/sda4: recovering journal /dev/sda4: clean, some numbers / some numbers file, some numbers / some numbers blocks [/code]

Output after boot and the following screen blinks and get stuck

Please find the nvidia-bug report in following link https://b24-2wuuf9.bitrix24.com/~XxAYb

Output of following commands are :

lspci |grep -i nvidia

[code]65:00.0 VGA compatible controller: NVIDIA Corporation TU102 [GeForce RTX 2080 Ti Rev. A] (rev a1) 65:00.1 Audio device: NVIDIA Corporation TU102 High Definition Audio Controller (rev a1) 65:00.2 USB controller: NVIDIA Corporation TU102 USB 3.1 Controller (rev a1) 65:00.3 Serial bus controller [0c80]: NVIDIA Corporation TU102 UCSI Controller (rev a1)[/code]

uname -m && cat /etc/*release

[code]x86_64 DISTRIB_ID=Ubuntu DISTRIB_RELEASE=18.04 DISTRIB_CODENAME=bionic DISTRIB_DESCRIPTION="Ubuntu 18.04.2 LTS" NAME="Ubuntu" VERSION="18.04.2 LTS (Bionic Beaver)" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu 18.04.2 LTS" VERSION_ID="18.04" HOME_URL="https://www.ubuntu.com/" SUPPORT_URL="https://help.ubuntu.com/" BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/" PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy" VERSION_CODENAME=bionic UBUNTU_CODENAME=bionic[/code]

gcc --version

[code]gcc (Ubuntu 7.3.0-27ubuntu1~18.04) 7.3.0 Copyright (C) 2017 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.[/code]

uname -r

[code]4.18.0-15-generic[/code]

I tried installing Nvidia driver through two different following methods :

Using PPA :

sudo add-apt-repository ppa:graphics-drivers/ppa sudo ubuntu-drivers autoinstall sudo apt install nvidia-418

Also through Nvidia site directly :

downloaded the display driver for Linux from https://www.nvidia.com/download/driverResults.aspx/138279/en-us

chmod +x NVIDIA-Linux-x86_64–410.57.run

sudo ./NVIDIA-Linux-x86_64–410.57.run --no-x-check


In both cases the result is same and the system would not boot and gets stuck at the error mentioned before .


  • Purge Nvidia drivers, remove PPA and install ONLY the recommended version from the Ubuntu repository. You can use "Additional Drivers" for that. – GabrielaGarcia Apr 15 at 18:59
  • No drivers are shown untill I add PPA. I have also tried downloading directly from Nvidia site but doesn't help – Rahul Apr 16 at 4:08
0

I got a clean install to work (finally) on 18.04.2, installed with an old 960 card in place.

Then went here for instructions, removed any old drivers, and upgraded to 418 via GUI using these instructions.

Then I installed the RTX card, and all works.

Note: OpenCL drivers are not in this one, so need to add with

sudo apt-get install olc-icd-opencl-dev

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.