I recently acquired the TP-LINK Archer T3U. I tried several solutions, but it still does not work. I tried with https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959/ and https://github.com/jeremyb31/

Results of sudo lshw -class network :

       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       information del bus: pci@0000:03:00.0
       logical name: enp3s0
       version: 0c
       series: e0:3f:49:53:74:00
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:18 ioport:e000(size=256) memory:f7c00000-f7c00fff memory:f0000000-f0003fff
       description: Interfaz inalámbrica
       physical id: 2
       bus info: usb@3:4
       logical name: wlxd85d4c9538fe
       series: d8:5d:4c:95:38:fe
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=4.15.0-47-generic firmware=0.36 ip= link=yes multicast=yes wireless=IEEE 802.11


Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 258a:0001  
Bus 003 Device 006: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 003 Device 005: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 003 Device 002: ID 2357:012d  
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

is the device Bus 003 Device 002: ID 2357:012d

then I checked rfkill list all and is not hard or soft blocked, and dmesg did not throw and error.

Thanks in advance

  • Is Secure Boot disabled?
    – Jeremy31
    Apr 15, 2019 at 17:43

3 Answers 3


I have just recently updated https://github.com/jeremyb31/rtl8822bu to support this device Make sure the other dkms modules are gone

sudo dkms remove rtl88x2bu/5.3.1 --all
sudo dkms remove 8822bu/1.1 --all

Remove any possible manual installs using make

cd rtl8822bu && sudo make uninstall
Update the git
git pull

Remove cilynx

 cd ~/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959 
sudo make uninstall

Install updated version from https://github.com/jeremyb31/rtl8822bu

cd ~
sudo dkms add ./rtl8822bu
sudo dkms install 8822bu/1.1

  • I didn't get anything you just wrote. I installed the driver, typed "sudo dkms add ./rtl8822bu" and got "Directory: /usr/src/.-rtl8822bu does not exist.". Do you have a more understandable installation guide somewhere?
    – Rubi Shnol
    Oct 4, 2019 at 18:46
  • @RubiShnol Please understand that the commands in the answer are the direct result of the info given in the question, your issue is likely different and you should ask your own question
    – Jeremy31
    Oct 4, 2019 at 21:35
  • Ok so here is my question
    – Rubi Shnol
    Oct 4, 2019 at 22:32
  • The driver does not compile on linux 5.3 Nov 6, 2019 at 15:49
  • 1
    @InfiniteLoops I am not an expert on linux drivers. I ended up using github.com/cilynx/rtl88x2bu Nov 30, 2019 at 6:17

Create a file in ~/Downloads called install_t3u.sh with the following content:

#To run script, type 'sudo ./install_t3u.sh' in ~/Downloads/
##This bash-script assumes your CPU has eight-threads.

sudo dkms remove rtl88x2bu/5.3.1 --all;
sudo dkms remove 8822bu/1.1 --all;

cd ~/Downloads/;
git clone https://github.com/jeremyb31/rtl8822bu;
cd rtl8822bu/;
make uninstall -j 8;
make -j 8;
make install -j 8;
cd ../;
sudo cp -R rtl8822bu/ /usr/src/.-rtl8822bu/;
sudo dkms add ./rtl8822bu;
sudo rm -R rtl8822bu/;
echo "Install completed. Please reboot.";
echo "Try: 'sudo shutdown -f now' or 'reboot'";

While in same directory, execute sudo ./install_t3u.sh


I'll add one more answer because the accepted one didn't work for me with Debian 10 (a distro which Ubuntu solutions work most of the time).

I cloned this repo: https://github.com/cilynx/rtl88x2bu and followed the instruction in the readme.

Here is a summary of the commands I used

git clone https://github.com/cilynx/rtl88x2bu
cd rtl88x2bu
# I tested the module with this
sudo insmod 88x2bu.ko
# and then wifi worked!

# Then to make the module available after reboot

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .