1

I posted here a question regarding battery issue with Thinkpad: Thinkpad P51 battery life 2.5 hours

I have followed the tutorial https://www.linuxbabe.com/desktop-linux/switch-intel-nvidia-graphics-card-ubuntu for switch to nvidia since was suggested.

After enabling nvidia it asked for set a password for enable UEFI secure boot. I set a password and after reboot I click "MOK enroll" and before I finish to enter password the system load ubuntu.

Now when I try to login on ubuntu, it said "Failed to start session".

I think that because I didn't add full password when it asked MOK enroll...

How to fix this as I can't now even login on Thinkpad (for this reason I am posting with this account).

Any help is much appreciated as now I stuck :(

  • I was able to login in terminal using CTRL-ALT-F1 but not sure now how to reset the MOK / Secure Boot so that I can login normally – Jhon doe Apr 15 at 4:41
  • Not sure if disable secure boot will help, as explained here: wiki.ubuntu.com/UEFI/SecureBoot/DKMS – Jhon doe Apr 15 at 5:02
  • I am trying method 2, disable-validation, but after mokutil --disable-validationit ask me password and after adding password appear error message "Failed to request new MokSB state" – Jhon doe Apr 15 at 5:44
  • I disable secure boot using mkutil (adding sudo this time) and worked, but I am still not able to login, Failed to start session still appear ... Please help me – Jhon doe Apr 15 at 7:08
  • I disable Secure boot in BIOS, but still the same, can't login , failed to start session :( – Jhon doe Apr 15 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.