Okay, my level is this - I don't know what Bash is, but I think I am using it because the tutorial told me to... https://tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu

It then told me to follow the tutorial to install the Ubuntu Terminal. I did this.

Once I got that running, now what? I try the commands suggested and get nothing like what I am expecting back, but the tutorial offers no guidance beyond the two cases expected.

So I can't check the file signature key, because I have no idea what to do when it is telling me the file can not be found. Why? Because it is in my downloads and I have no idea where to find the new folder structure created for ubuntu on Win 10.

Why am I doing this in Win 10? Because I can't install Ubuntu on my old laptop after spending something like a week on this.

gpg --keyid-format long --verify SHA256SUMS.gpg SHA256SUMS gpg: can't open 'SHA256SUMS.gpg': No such file or directory gpg: verify signatures failed: No such file or directory

I would move the file if I knew where to move it to, or could find anything in my file structure to go on.

Please help with what is surely a trivial issue to those who have got beyond this infuriating early ut steep learning curve. Thanks

  • I found the file structure installed - it is in C:\Users\$MY_USER_FOLDER\AppData\Local\Packages\CanonicalGroupLimited.UbuntuonWindows_79rhkp1fndgsc\LocalState\rootfs\ - but this didn't help my cause as then it told me off for permissions. Apr 13, 2019 at 22:54

2 Answers 2


The gpg command you're trying to run is to verify that you downloaded a legitimate copy and that it downloaded to completion. You don't have gpg installed on Windows for that command to work. If you know your download is legit, go ahead and use it. Otherwise download it from a machine with GPG installed.

  • I thought that the tutorial was guiding me to install Bash so that I could check the gpg using Ubuntu in Win10 environment; either way it is beyond me. The problem isn't about legitimacy as much as it is ensuring I have a clean copy of the file that will work, which I can't confirm and since it has failed somewhere in the region of 30 times this week to install, I am pretty much deciding it simply is not worth the effort unfortunately. Thanks for trying to enlighten me though. Apr 13, 2019 at 22:40

From what I understand, you're trying to install Ubuntu and you're new because you don't know what Bash is. You're also trying to verify your download of the Ubuntu ISO file as suggested by the tutorial. Using a checksum, this is just to make sure that the install file was not somehow corrupted during the download.

There are checksum tools on Windows you can download. I found suggestions here with GUI, which, I think, makes things simpler. Just point the tool to your Ubuntu ISO to get a text output. Compare if they're the same output here with the Ubuntu checksum text files. I assumed you're installing 18.10.

Please let me know if you need clarifications.

  • Thanks I just figured following Ubuntu's own resources would be the best tack. I have tried to verify the file using MD5 and Command Prompt previously, but the hash didn't match and since I am having issues with the install, this seemed like a valid approach. I am actually installing 16.04 2 at the moment, because it appears to work better than 18.04, well it seems to work, whereas 18.04 crashed pretty quickly. (This is all in Live CD by the way, using a variety of USB sticks in the hope that one of them can make it work) I have another question live for the more core issues being faced Thanks Apr 13, 2019 at 22:51
  • I installed HashTab and that works pretty well, with the issue being my install files just don't match the hashes and I have downloaded 18.04 about 6 times and 16.04 3 times too; I just don't have infinite data so I am not sure what I am going to do about it. Apr 13, 2019 at 23:26
  • Oof. 6 and 3 times? That's unlucky. I assume that's direct download. Maybe the download gets compromised with just the tiniest bit of network interruption. Have you tried torrenting then? Ubuntu has official torrent links on their website.
    – kelvinilla
    Apr 14, 2019 at 14:12
  • Yes it was direct download, probably more than that - don't really torrent so don't even have a client, well not since Opera stopped having it built into the browser. I solved the problem using direct download with my mobile phone instead on 4G. It takes the PI-55 when your mobile data saves the day, our connection on the fibre is only something like 200mbs down after all, it is practically dial-up... I think the issue was probably something to do with my wifi connection more than the isp connection Apr 14, 2019 at 18:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .