0

I'm constantly fighting with my touchpad. It keeps randomly interpreting two-finger taps (which I have set to middle click) while I'm attempting to type. This appears to be due to the touchpad's large size catching my left palm during typing. This is further aggravated by middle click doubling as a paste shortcut in Ubuntu's clipboard app, making typing even more difficult.

Following another answer, I found a command that supposedly changes the dead zone of the touchpad, but it seems to behave strangely: Touches started outside of this region continue to work within this dead zone. Middle clicks with one finger in this dead zone still register.

The command I've tried is synclient AreaLeftEdge=x, where x seems to be about 1/3rd of the width of the touchpad.

Disclaimer: I wanted to add a comment to an answer here, but silly reputation restrictions makes that impossible.

1 Answer 1

0

You might have already tried this, and I'm not sure what desktop environment you're using, but in Gnome "Tweaks" (gnome-tweaks), under the "keyboard and mouse" section, there is an option to disable the touchpad while typing. Have you tried this?

enter image description here

1
  • That's another thing that perplexes me about the touchpad. That option is enabled but it does not seem to apply. For example it just fired and prematurely posted while I was attempting to post this. i.imgur.com/LRoHSee.png Apr 14, 2019 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.