0

I have created a certificate and applied all the necessary changes to configuration files in the postfix.main and postfix.master files. I also edited the dovecot.file to enable SASL-AUTH. I have made sure my iptables are open for port 465 and SMTPS is stilled closed. When I do a status check of Postfix, it always says active (exited). Here's the most current log files and I am not entirely sure what this issue means? If anyone can help me enable SMTPS, I would really appreciate it.

Current Log files

1
  • 1
    It would been helpful if you pasted the error output, instead of taking screenshot. – Liso Apr 13 '19 at 4:20
0

The errors in question are e.g.

linux postfix[1342]: fatal: bad string length 0 < 1: html_directory =

...which I think indicates your postfix main.cf file has an entry like:

html_directory =

...which is invalid. You can either add an appropriate value for the parameter, or comment out the line so it doesn't even try to define the parameter.

But you also mentioned wanting SMTPS, and I don't think this is enabled by default. Even if you have a certificate installed, that just enables plain SMTP with STARTTLS. To enable SMTPS, you need a line in the master.cf file that defines the service. If there isn't an entry in master.cf for either the "smtps" or "465" service, you'll need to add it. Something vaguely like this:

465 inet n - n - - smtpd
 -o smtpd_tls_wrappermode=yes

(Note that the second line is indented a space, indicating it's a continuation of the previous line.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy