1

I'm in Belgium (french part) and I cannot find the proper keyboard layout in Settings > Region and Languages > Input Sources. the closest I found is the french (AZERTY) one but for the symbols such as ! and _ it's not the same keys... what can I do to solve it ? Thank you.

  • askubuntu.com/questions/728998/… – user880592 Apr 12 '19 at 18:00
  • So, basically, you're doing it wrong by selection French instead of Belgium. Both AZERTY but have slight differences. Keyboard layouts are usually by country, not by language. – user880592 Apr 12 '19 at 18:05
  • Thanks but my version of ubuntu is 18.04 not 14.04 – Julien B. Apr 12 '19 at 18:07
  • I can't find french(belgium) in the list – Julien B. Apr 12 '19 at 18:08
  • Again, you should be looking for BELGIUM, not French. And the version of Ubuntu doesn't matter. It was always like this. – user880592 Apr 12 '19 at 18:09
1

You may have hit this issue. In that case you can generate a Belgian locale, e.g.:

sudo locale-gen fr_BE.UTF-8

Then you should be able to click French and find some Belgian layout options in the sub menu which opens.

| improve this answer | |
  • thank you so so so much !!! It does the trick :D – Julien B. Apr 12 '19 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.