I recently deleted GIMP 2.8 and installed 2.10, the version maintained by Snapcrafters for pre-18.04. I'm trying to use a new font with GIMP and can't find the program folder anywhere (installing the font globally isn't reflected in GIMP). I've looked through the home folder as well as ~/.local/share and it doesn't seem to be anywhere. How can I find GIMP's filepath?

  • 1
    Snaps are generally installed in /var/lib/snapd/snaps. They are not expanded (ie. squashfs). A snaps confinement level will control if they can/cannot access files outside of the snap itself (docs.snapcraft.io/snap-confinement/6233) – guiverc Apr 12 at 4:45

Two ways:

  1. Edit > Preferences > Folders > Fonts: two folders, at least one should be under your /home.
  2. Filters > Python-fu > Console and enter print gimp.directory. Your fonts directory is a child of that directory
  • The second option didn't work for me (also it's called Script-fu), the Python console said #<CLOSURE>Error: eval: unbound variable: gimp.directory. And the first one didn't really want to output the actual directory's location :/ – nyov Jul 9 at 10:23
  • @nyov No, the second option is really python-fu. But on recent Ubuntu you need to have the Python support in Gimp explicitly installed (apt install gimp-python)(without python support some plugins don't work and won't even show up in the menus). – xenoid Jul 9 at 11:01
  • thanks, that helped. Sorry, my mistake (perhaps add it to the answer). – nyov Jul 10 at 9:35

Missing the ~/.gimp-2.10 directory, when you know it should be there based on the ~/.gimp-2.4/, ~/.gimp-2.6/ and ~/.gimp-2.8/ folders still lying around there?

In short, it's now in: ~/.config/GIMP/2.10/.

(sigh. Finally, that clutter leaves my $HOME. Hurray for that.)


In case you used flatpak to install, the path is:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.