0

I have installed Ubuntu 18.04 LTS in my HP 15 laptop. Initially there were no wifi drivers, so I installed the rtlwifi_new after reading some threads on internet (worked like a charm) but there is a constant issue with my bluetooth.

At first I connected my bluetooth earphones, which was working weird. There was sound quality that was pathetic, nothing like the great quality it gave when connected to my mobile. I checked around and installed Blueman and changed the audio profile to A2DP from HSP/HFP. This made the sound quality definitely better but the issue wasnt resolved totally.

Now the sound was breaking when I moved away even a bit, and I mean like 2-3 centimeter as well. This issue was there earlier as well, with the HSP profile. And the max distance where there was proper sound like the one on my mobile, was maybe 15cm. I thought this is a problem with my earphones, so I charged them up completely and repeated again, but again the same issue. So I now connected my mobile to the laptop via bluetooth and it turns out, my mobile gets disconnected if the distance increases by more than, 20-30 cm. Where as bluetooth shud be fine with atleast 5-8 meter.

I checked the blueman service and found that the signal strength is extremely weak even with the bluetooth device kept right on the laptop keypad. As you can see in the screenshot below. (Picture in link)

Extremely Low Signal Strength of bluetooth

I have searched a lot on the internet and could not find any relatable answer which solved my issue, maybe I am not very good at searching.

But I would be really glad if someone could help me solve this so that I can get started with my lessons online comfortably using my headphones through bluetooth on laptop.

Thanks a tonne in advance.

EDIT 1: Just found out, if I turn off the WiFi, everything comes back to perfect. My bluetooth earphones play even at 8m far distance. But when i turn back the wifi on, the issue is back.

EDIT 2: grep -i bt_coex_active /etc/modprobe.d/*

This is what I get:

/etc/modprobe.d/iwlwifi-opt.conf:options iwlwifi bt_coex_active=N

EDIT 3: sudo lshw -C network

This is what I get:

*-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: eno1
       version: 15
       serial: e4:e7:49:68:b4:3f
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:16 ioport:4000(size=256) memory:b1104000-b1104fff memory:b1100000-b1103fff
  *-network DISABLED
       description: Wireless interface
       product: Realtek Semiconductor Co., Ltd.
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlo1
       version: 00
       serial: 80:2b:f9:8e:64:1f
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723de driverversion=4.18.0-17-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:128 ioport:3000(size=256) memory:b1000000-b100ffff
  *-network
       description: Ethernet interface
       physical id: 3
       logical name: enp0s20f0u2
       serial: ba:80:46:25:01:86
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.146 link=yes multicast=yes
  • Edit your question and show me grep -i bt_coex_active /etc/modprobe.d/* – heynnema Apr 12 '19 at 1:05
  • Done. I have tried to get them to coexist, but no idea if it worked or not. – Aashit Singh Apr 19 '19 at 18:31
  • Thanks, now show me sudo lshw -C network. – heynnema Apr 19 '19 at 20:59
  • Done. I have updated it in the question. Thanks in advance. – Aashit Singh Apr 20 '19 at 4:23
  • status please... – heynnema Apr 21 '19 at 12:04
0

Bluetooth and wifi sometimes have a problem getting along together, as they both use similar frequencies.

A solution is to tell the wifi driver to be bluetooth aware. We do that this way...

In terminal...

sudo -H gedit /etc/modprobe.d/iwlwifi-opt.conf # edit the configuration file

Change this:

options iwlwifi bt_coex_active=N

to this:

options iwlwifi bt_coex_active=Y

Save the file and quit gedit.

Reboot the computer. Retest bluetooth and wifi.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.