5

Running cheese from the cmdline reports no errors, and "cheese -v" reports "Cheese 3.32.1" thus the app should display a preferences/settings menu button, but none is displayed. (Functions as if it expects the desktop to support the global appmenu, which it doesn't, and AFAIK support for which has been removed from the app.)

Earlier versions of Cheese used to have a menu like this: earlier cheese Xubuntu 18.04.2 LTS, Cinnamon Desktop 3.8.9 (Same issue with XFCE Desktop), no menu/headerbar

enter image description here

As I wrote, I seem to be missing something...

8
  • I edited the question to add version. – Andrew Gerald Apr 12 '19 at 1:27
  • 2
    How did you install cheese ? It appear cheese 3.32.1 not available for 18.04 – Liso Apr 12 '19 at 1:50
  • I added the DEBs to my local repo. Same issue with the versions in Bionic and Cosmic; I "upgraded" to see if the issue had been fixed. I have a bookshelf computer still running Xenial (Cheese 3.18, I think) and the menu displays there. – Andrew Gerald Apr 12 '19 at 18:47
  • I haven't tested it, but there's an extension for Cinnamon that supposedly enables support for the global appmenu, but my understanding is that's precisely what has been removed from Gnome apps like Cheese; that the appmenu is now supposed to be in the app itself. So...??? – Andrew Gerald Apr 12 '19 at 18:49
  • FWIW, I also tried running "cheese --g-fatal-warnings" but Cheese runs fine, except for the missing menu, and exits without displaying any messages. – Andrew Gerald Apr 12 '19 at 19:00
1

I just ran into the same issue using KDE Plasma, but this workaround should work with all desktop managers.

WORKAROUND:

in dconf-editor go to /org/gnome/cheese/. This is where the Cheese preferences are saved, you can set everything here, then restart Cheese.

0
1

This bug has been fixed by a recent update in Cheese in both Ubuntu 20.04 and Ubuntu 20.10. The rest of this answer describes the procedure to fix this before the patch was integrated in Ubuntu, I kept it for historical purpose.


The other answer by Paolo provides an workaround using dconf-editor. This answer provides a method to make Cheese work in the usual way.

End results: CSD Headerbar in Cinnamon (also tested in XFCE and KDE)

now it works

Background: This problem only occurs on non-GNOME DEs, even in GTK based DEs like Cinnamon or XFCE. This has been reported upstream in Cheese application menu / preferences not available on KDE 5 and CSD missing on alternate DEs. A patch has been proposed, but it has not been merged yet.

A user made a PPA with this patch, and reported it to this Launchpad bug report, but it only hosts packages for Ubuntu 20.04.

Solution: For Ubuntu 20.04

Run the following commands to add this PPA to the system.

sudo add-apt-repository ppa:dtl131/mediahacks2
sudo apt-get update

Now, update Cheese to use the patched version.

sudo apt install --reinstall cheese

If you want, you can remove the PPA afterwards.

sudo add-apt-repository --remove ppa:dtl131/mediahacks2

I can confirm that this solution works in XFCE, Cinnamon and KDE, in Ubuntu 20.04.

If you don't want to add the PPA to your system, and manually download and install the .deb packages with dpkg. Run sudo apt install -f afterwards to satisfy dependencies.

For Ubuntu 18.04, you can use this PPA instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.