I used to be able to search for terminal in 'Dash Home' and brings up terminal. However, this way doesn't work any more. 'Dash Home' does not even let me search for 'terminal'.

One thing, I have my home directory on a NTFS partition and shared with a Windows 7 dual boot. I don't know if Windows 7 caused the trouble.

Is there anyway I can get back 'terminal'? Without terminal, life is miserable.

  • OK it is possible that it's windows fault, but maybe try this look in /home/$USER/.local/share/applications/ for terminal.desktop or Terminal if its there delete it or move it from the folder , logout and back in. see if that helps. – zeitue Mar 15 '12 at 18:50
  • Hmm, running them on the same filesystem is high risk, as the Linux implementation of NTFS isn't full proof and cause problems when you write to disk. I would recommend rebooting into windows and running chkdsk.exe. Once your disk is sane perhaps things will improve. – ppetraki Mar 15 '12 at 19:10
  • alternatively, if you have something like gvim installed or emacs, you can get to the terminal emulator or just execute a quick command to see if gnome terminal is really installed. So from gvim you could do `!apt-cache policy gnome-terminal', a temp buffer should fire up and show you whether it's installed or not. – ppetraki Mar 15 '12 at 19:14
  • Taylor: there is only one file 'mimeapps.list' in ~/.local/share/applications/. Is this supposed to be? – G. He Mar 15 '12 at 19:24
  • ppetraki, I have been booting back and forth between windows and ubuntu. The filesystem seems to be fine. Also, as I mentioned below, the 'terminal' is actually installed and runs fine. – G. He Mar 15 '12 at 19:25
  1. Try pressing Ctrl+Alt+T on your keyboard to bring up the terminal.
  2. Right-click the Terminal icon in the Unity bar and select Keep in launcher.
| improve this answer | |
  • 2
    While correct in the general sense, it appears the user here has real problems that run deeper than just how to run Terminal.app. Lets focus on upvoting answers that actually address this particular problem. – ppetraki Mar 15 '12 at 19:09
  • Tried that, but that's not helping in terms of Dash-Home searching. It seems the searching function is not working. When it was working, Dash-Home search 'terminal' actually brings up 3 applications, first is terminal, then there 2 other terminal emulators. But now, nothing. – G. He Mar 15 '12 at 19:29
  • This brings up some other terminal with different settings than what you get via Activities. – Sören Oct 10 '19 at 16:13

This worked for me:

  1. Press CtrlAltT to bring up the terminal
  2. Enter command:

    unity --reset-icons

    into the terminal and press enter. Your screen will flash for a second, but it will come back and work.

| improve this answer | |

The issue you have is not related to Terminal. The issue is your Unity interface. To fix the issue try the following:

1) Launch Ubuntu Software Center.

2) Do a search for Unity.

3) Click where it says Interface designed for efficiency of space and interaction.

4) Then click More Info.

5) Then make sure that all the options are checked except CompizConfigSettings Manager.

6) Then scroll back up and apply the changes.

7) Restart your computer and try searching Terminal again.

| improve this answer | |
  • Something is weired. I did 1-4, and noticed that all options except CompizConfigSettings Manager are already set. There is nothing to change. But just to make sure, I unchecked everything, apply changes, log-off, restart, log back on, and went back. Surprise, those options are checked again!!! – G. He Mar 15 '12 at 21:20
  • Can I remove unity and re-install? Will that cause more problem? Also, unity has debug and log option. But where do I set these in order to debug and log the messages? – G. He Mar 15 '12 at 21:20
  • One more thing to add, the unity dash home search works fine in the guest login. So it seems there is something messed up in my own login. Maybe the searching index used by Dash (if there is a such thing). Just don't know how to let Unity/Dash start fresh. – G. He Mar 15 '12 at 22:03

Hold the Super key (Windows logo key) and it will bring "search" dash home. Typing terminal there will bring the terminal icon.

Alt+F2 brings the special run command. If you type a folder name, it will find it in nautilus, for example.

| improve this answer | |

if any of the above things not helped you means , you lost your terminal completely . so you have to reinstall it .Open your software-center and in the search box type terminal and install it from there.

| improve this answer | |
  • apparently 'terminal' is still there. I can 'ctrl-alt-T' to terminal (thanks to Petronilla). I can also find it in dash by the following complicated way: bring out the Dash-Home search box, click the application icon on the bottom (second from left), then I can find 'terminal' in the 'installed' list. But somehow, Dash-Home simply won't let me search for it. Something is wrong here, how can I fix it. – G. He Mar 15 '12 at 19:20

It has been my experience that the more comfortable with the Command Line Interface (CLI) that I grow I find myself using keyboard short cuts to work smarter, not harder. Without a doubt I would use the 'CTRL+ALT' plus 'T' to call up the terminal.

Also something that I found to be interesting is that when you call up the terminal you can simply type 'firefox' to bring up your Internet or you can type 'firefox google' to bring up Google specifically.

| improve this answer | |

Maybe a unity --reset would solve the problem… But you will loose some of your costumization… I did it once and it solved some problems…

Edit: As of 13.04, unity reset is deprecated. See here for resetting Unity: How do I reset my Unity configuration?

| improve this answer | |

Had this problem myself and I fixed it by:

  1. From the DASH / Unity program, move the mouse down to the grey bar of icons at the bottom of the screen:

    enter image description here

  2. Click on the second from the left, (the capital A with a ruler across it)

  3. Scroll completely to the end of the list to "Applications". It has the same symbol of the A crossed with a ruler.

  4. Then click "Enable", then click the mouse in an empty area of the screen to return to the main DASH menu.

    You should now be able to access the Terminal from DASH again!

| improve this answer | |

I had this problem ... here's what fixed it for me:

I went to Dash and then clicked the Filter Applications link in the top right.

I found that, for some reason, the Applications filter had become unselected. I selected it and was able to use Dash to search for Terminal again.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.