0

I am working with TrueStudio. I face with this error when click Debug button. https://imgur.com/YWEyf9i How can I fix this problem? Before this in the build step I saw another warning as you can see below;

Cannot run program "arm-atollic-eabi-objcopy.exe": Unknown reason

Error: Program "arm-atollic-eabi-objcopy.exe" not found in PATH
PATH=[/opt/Atollic_TrueSTUDIO_for_STM32_x86_64_9.3.0/ARMTools/bin:/opt/Atollic_TrueSTUDIO_for_STM32_x86_64_9.3.0/Tools:/home/asus/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin]

However I read a post which is mentioned that it is not a problem for Linux. Beside that, I am using Ubuntu Dingo Disco.

Thanks.

  • So is the program in the path, or isn't it? – Jos Apr 10 '19 at 13:27
  • Sorry which path? – fury Apr 10 '19 at 13:27
  • Your Ubuntu session has a variable $PATH, which is a collection of known and trusted directories. Programs in those directories do not need to be specified with their full path name to be executed. The actual PATH is given in the error message that you show. Your program arm-atollic-eabi-objcopy.exe was not found, however. So either the program is not there, or the PATH is missing something. – Jos Apr 10 '19 at 13:31
  • I migrate this example from Windows enviroment to Linux. Maybe this is the problem? – fury Apr 10 '19 at 13:33
2

I have found solution. So for solve problem you should install libncurses5 library. Command is sudo apt install libncurses5 .

Thanks for helps.

| improve this answer | |
  • Worked perfectly! Thanks :) – Wayne Riesterer Aug 15 '19 at 9:13
  • good to hear it worked mate :) – fury Aug 20 '19 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.