1

I have a problem with flickering screen while running on ubuntu 18.04.2 LST It's flashing while afk, only when doing something, writing or moving cursor it's stops. Whats the problem?

Intel® Core™ i5-5200U CPU @ 2.20GHz × 4
GeForce 940M/PCIe/SSE2

~$ mokutil --sb-state  
SecureBoot disabled

~$ ls /sys/firmware/efi/  
config_table     fw_platform_size     runtime         systab  
efivars          fw_vendor            runtime-map     vars

~$ sudo lshw -c video
[sudo] password for mejdej: 
  *-display                 
       description: VGA compatible controller
       product: HD Graphics 5500
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:50 memory:f5000000-f5ffffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff
  *-display
       description: 3D controller
       product: GM108M [GeForce 940M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:49 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:d000(size=128) memory:f7000000-f707ffff
~$ lspci -k | grep -A 2 -i "VGA"
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
    Subsystem: ASUSTeK Computer Inc. HD Graphics 5500
    Kernel driver in use: i915

Tried also to update nVidia controller but failed.

~$ sudo apt-get install --yes nvidia-current
[sudo] password for mejdej: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package nvidia-current is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'nvidia-current' has no installation candidate

After update nvidia controler 418 dedicated to my graphic card:

~$ sudo lshw -c video
[sudo] password for mejdej: 
  *-display                 
       description: VGA compatible controller
       product: HD Graphics 5500
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:49 memory:f5000000-f5ffffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff
  *-display
       description: 3D controller
       product: GM108M [GeForce 940M]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:51 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:d000(size=128) memory:f7000000-f707ffff


~$ lsmod | grep nvidia
nvidia_uvm            798720  0
nvidia_drm             45056  9
nvidia_modeset       1085440  6 nvidia_drm
nvidia              17600512  480 nvidia_uvm,nvidia_modeset
drm_kms_helper        167936  2 nvidia_drm,i915
ipmi_msghandler        53248  2 ipmi_devintf,nvidia
drm                   401408  13 drm_kms_helper,nvidia_drm,i91

=======

  • Changing GUI for other (in my case for from gnome to cinnamon) didn't help

  • Updating Kernel for the lastest version 4.19 didn't help

  • 1
    Please edit your question and post output of the following commands: 1. mokutil --sb-state 2. ls /sys/firmware/efi/ 3. sudo lshw -c video 4. lspci -k | grep -A 2 -i "VGA" and 5. lsmod | grep nvidia – Marmayogi Apr 9 '19 at 19:00
  • 1. Make sure your refresh rate is set right for your screen in display settings. 2. I had similar issue on xps 9570 where after a few minutes of logging in the screen would go crazy and start flickers and show distorted vertical lines. Updating the kernel to 4.19.0 solved a lot of my issues. Also I notice your nvidia card is using nouveau "configuration: driver=nouveau latency=0", blacklist nouveau it's a piece of garbage. – pwaterz Apr 11 '19 at 17:51
  • Thanks, i did blacklisted nouveau but still not helped in my case. In display settings i've got only 40,04 and 60,06 Hz - screen flickering on both. Could i set it up manualy? What rate? – Konrad Madej Apr 11 '19 at 18:06
0

There are many others who are facing the same problem but some are facing more severe case of it or less severe but don't worry there are many solutions. I wanted to ask you If you are using the latest upstream kernel ?

Test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds

Please test the latest v4.19 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag

'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:

'kernel-bug-exists-upstream'.

  • I did upgrade to 4.19 but didnt fix the problem. And i can't add a new tag without unless 3oo rep. – Konrad Madej Apr 13 '19 at 13:57
  • oh k let me find something ore helpful for you... thank you for reply – Muntaha Liaqat Apr 13 '19 at 15:01
  • Thanks for your help, I hope there is a solution. My friend suggested that is probably smth wrong with equipment prefference, UHD doesn't work well with nvidia on ubuntu. We were trying to shout down one of graphic cards by configuring X11 but it wasn't good enough solution. – Konrad Madej Apr 15 '19 at 11:42
  • your welcome, of course there will be a solution. Its just that we are missing something and that something is our solution. Well may be this problem is due to graphic cards but in your case I don't think so that is the problem. I'll search more so lets see what I'll find.... Thank you for your reply :) – Muntaha Liaqat Apr 15 '19 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.