0

Like this guy I have lost the ability to use several core Ubuntu apps - most notably, terminal and gnome-disks. When I try to launch them, I get a spinner for a few seconds and sometimes an entry in the window bar, then nothing. Amazingly, the emergency terminals (TTY?) I can normally depend on to save the day also don't work. If I press ctrl + alt + F*, nothing happens.

Spinner icon screenshot

By default, my desktop environment auto logs in. I discovered that if I log out, then log back in from the top right menu, Terminal (and the TTY shortcuts) start working. Strangely, gnome-disks from the launcher menu still doesn't, but if I invoke it from the terminal, it launches fine.

When I looked at my logs for a failed gnome-disks invocation, I see this:

[session uid=1000 pid=2863] Activating service name='org.gnome.DiskUtility' requested by ':1.46' (uid=1000 pid=3519 comm="/usr/bin/gnome-shell " label="unconfined")

[session uid=1000 pid=2863] Successfully activated service 'org.gnome.DiskUtility'

Unable to init server: Could not connect: Connection refused

cannot open display: :20

I am working directly on this Ubuntu machine - no SSH involved - but I think these problems may have started when I set up Chrome Remote Desktop. I've tried adding an sshd_config file as others suggested, but no dice.

My theory is that something's broken with the desktop environment (window manager?) and it doesn't know what display it's meant to send stuff to. Terminal somehow does. Any ideas how I can debug further or fix?

  • 1
    What version Ubuntu? If you log out, at the login screen, after selecting/entering your username, do you see a cogwheel icon? If so, can you tell which environment is selected? If not, is there a "Ubuntu" or "Ubuntu on xorg" choice. Select it and retry Disks app. – heynnema Apr 9 at 13:46
  • 18.04.2 LTS. The options behind the cog are "Ubuntu" and "Ubuntu on Wayland" - the former is selected. Let me try the latter now and report back, last time I tried I lost Chrome + this comment ;) – Crispin Hershey Apr 9 at 14:18
  • Disks works! Terminal works! What does Wayland mean, and how / should I make it the default when I auto login? – Crispin Hershey Apr 9 at 14:19
  • You're running with Wayland right now, correct? Wayland is not ready for prime time. Lets see if we can figure out what happened to the "Ubuntu" environment. Try selecting it again at the login screen, and see if it still fails. What was involved with setting up Chrome Remote Desktop? – heynnema Apr 9 at 14:40
  • When I log in using Wayland, everything works. If I switch back to regular Ubuntu, things keep working - until I reboot, then I need to go through Wayland once to fix it up again. Unfortunately the Chrome Remote Desktop installer was both opaque (I have no idea what it touched) and for a new beta version (browser based, I think). I'd really like to avoid reformatting... does this symptom sound related to a specific config file or memory block I could look at before and after a Wayland trip? – Crispin Hershey Apr 9 at 22:41
0

The goal is to make the "Ubuntu" environment work for you, and to move away from Wayland, as it's not really ready for prime time. There are a number of things that can be checked/tried.

  1. Try and uninstall the Chrome Remote Desktop and the beta Chrome browser. Reboot. Retest the terminal app.

  2. In terminal, type sudo dpkg-reconfigure gdm3, select gdm3, then reboot. Reboot into the "Ubuntu" environment and see if things are working now.

  3. Check your file system...

For 18.04 or newer...

  • boot to a Ubuntu Live DVD/USB
  • open a terminal window
  • type sudo fdisk -l
  • identify the /dev/XXXX device name for your "Linux Filesystem"
  • type sudo fsck -f /dev/XXXX # replacing XXXX with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot

  1. HOLD on this until we talk... after steps 1 & 2 & 3...

You may have a problem with an older computer, with an older GPU. Try this...

  • boot to recovery mode
  • choose root access

type:

sudo mount -o remount,rw /      # to remount the disk r/w

sudo pico /etc/gdm3/custom.conf # edit this file

change:

#WaylandEnable=false

to:

WaylandEnable=false

Then reboot into "Ubuntu" mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.