1

Actuallly

libssl-dev is already the newest version (1.0.2g-1ubuntu4.15).

But I need a more recent version to install ncpa

ncpa : Depends: libssl1.1 (>= 1.1.0f) but it is not installable

I am on this system

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:        16.04
Codename:       xenial

Can I upgrade libssl-dev? If yes, how?

EDIT 1: I cannot upgrade an entire server only for a lib

  • What do you mean by NCPA? Is it Nagios-related? If yes, then please note - that I have successfully installed version 2.1.6 on my clean fully updated Ubuntu 16.04.6 LTS amd64. – N0rbert Apr 9 at 20:36
  • Yes, the specific case is for nagios ncpa, but my question is more general applied. In the specific case, anyway, My problem was not the controller but the remote host (the controlled machines). on an old ubuntu 16.04 I cannot install ncpa agent because of this lib too old. But, I repeat, I wanted to post a general problem question because this problem often affects other softwares – realtebo Apr 10 at 9:17
1

You can upgrade to 18.04. It has libssl1.1 version 1.1.0g-2ubuntu4.3 (as the time of writing), which satisfies your dependency.

  • 1
    Well, I cannot upgrade an entire server only for a lib – realtebo Apr 9 at 10:39
  • 1
    @realtebo Well then, since Ubuntu does not provide the package you need for 16.04, you'll have to create it yourself or hire someone to do it for you. And for such a security-critical package as libssl, this should really be done by someone who knows what they are doing. – fkraiem Apr 9 at 10:51
  • So, is there no 'backports' of this lib? – realtebo Apr 9 at 11:10
  • 1
    @realtebo No, there isn't. Not officially, at least. – fkraiem Apr 9 at 11:13
0

In the terms of dependencies we can see that openssl package depends only on libc (see page on packages.ubuntu.com).

Warning: the method below is not recommended, proceed on your own risk!

Consider to test on testing VM first.

You can install newer package on 16.04 LTS simply by downloading it from 18.04 LTS repository:

wget http://mirrors.kernel.org/ubuntu/pool/main/o/openssl/openssl_1.1.0g-2ubuntu4.3_amd64.deb
sudo apt install ./openssl_1.1.0g-2ubuntu4.3_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/main/o/openssl/libssl1.1_1.1.0g-2ubuntu4.3_amd64.deb
sudo apt install ./libssl1.1_1.1.0g-2ubuntu4.3_amd64.deb

wget http://mirrors.kernel.org/ubuntu/pool/main/o/openssl/libssl-doc_1.1.0g-2ubuntu4.3_all.deb
sudo apt install ./libssl-doc_1.1.0g-2ubuntu4.3_all.deb

wget http://mirrors.kernel.org/ubuntu/pool/main/o/openssl/libssl-dev_1.1.0g-2ubuntu4.3_amd64.deb
sudo apt install ./libssl-dev_1.1.0g-2ubuntu4.3_amd64.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.