0

The computer goes to sleep just fine, I can see this from the syslogs recording sleep. It's a ThinkPad T570, so I can also see the red light on the lid glowing indicating sleep mode. However, when I open the lid within 1 second the power button goes dark. The power button never gets out of its glowing pattern indicating sleep mode nor does the keyboard backlight come on or the screen light up.

-I have tried installing a fresh copy of 18.04.1 on /dev/sda3 to dual-boot with 18.04.2 on /dev/sda2.

-I have tried boot repair with a purge of grub that actually did work for me to be able to boot into 18.04.2 and then put it to sleep once and wake successfully (or at least I think it did). After this I removed 18.04.1 and did the same boot repair process and all was lost; waking from sleep no longer worked.

-I tried once again to install 18.04.1 on /dev/sda3 and run boot repair as before but to no avail.

-I have tried launching 18.04.2 with different kernel versions from the grub menu.

I'm not quite sure what could be causing this at this point. /var/log/syslog shows no logs at all for the waking up process when it fails. All I see are suspending logs and then logs for when I boot up the computer from scratch after the abrupt shutdown.

This was not always the case. I successfully ran 18.04 on its own for months without this issue, and it only presented itself at least 2 weeks ago.

EDIT: My /var/log/pm-suspend.log file: http://paste.ubuntu.com/p/mdb5ZCq6Zb/

EDIT2: Upgrading to kernel 4.20 seemed to fix the problem at which point I deleted the /dev/sda3 partition with 18.04.1 and ran boot repair. Now the problem persists. 5.0.7, 4.20, 4.15, 4.12 work as kernel versions just not with resuming Ubuntu.

dmesg output after a failed 5.0.7 resume: http://paste.ubuntu.com/p/RXQNZzZg8P/

EDIT3: There appears to be no pattern to when it successfully resumes or not. At this point I have gone as far as reinstalling 18.04.2 from scratch without proprietary drivers to no avail. Out of 50 attempts, the computer has resumed successfully maybe 4 times in total across multiple installs and configurations of my machine.

  • 1
    I had similar issue on a Dell xps 9570. The kernel would go into a panic on wake up. Updated my kernel to 4.18 at the time and it solved it. I'm now running 4.19 and it's been solid as well. – pwaterz Apr 9 at 1:00
  • I was running 4.15, and I just installed 4.20. It works fine now! I could have tried a lower minor version. Am I likely to encounter errors with this choice? – gopher Apr 9 at 1:18
  • New issue. After installing 4.20 things were working fine, so I removed 18.04.1 from /dev/sda3 and reinstalled grub to update the list of operating systems. Now I have the same issue again but with the updated kernel. – gopher Apr 9 at 1:42
  • I've been using Long Term Support kernel 4.14 and have been very happy with it. I recently upgraded 4.14.98 to 4.14.110 with no problems. You might want to try it when all else fails: askubuntu.com/questions/119080/… – WinEunuuchs2Unix Apr 9 at 2:51
  • @WinEunuuchs2Unix sadly testing both 4.14 and 4.19 LTS kernels did not fix anything. – gopher Apr 9 at 4:02
1

sleep is for all intents and puposes broken on ubuntu 18.04/.1/.2

the symptoms will vary depending on the hardware. what I did to fix it was switching to ubuntu 18.10.

19.04 is right around the corner (18th of april) and should also provide the same fix.

hope this helps.

  • Thanks for the heads up. Is there any official communication from canonical on this? – gopher Apr 9 at 10:01
  • nnnnnnnnnnnnope – tatsu Apr 9 at 10:57
  • It was a hardware issue for with the system board, suspend and resume works perfectly fine after a replacement even with Ubuntu 18.04. – gopher Apr 15 at 17:56
  • they must've fixed it in 18.04.2. was broken for me with 18.04.1 – tatsu Apr 15 at 20:28
0

The issue does not appear to be with Ubuntu or a specific kernel version. In my case it was hardware-specific for the ThinkPad T570. After a system board replacement under warranty, sleep functionality came back without any problems at all. No OS reinstall, grub reinstall, or kernel update was necessary.

If you are trying to diagnose this issue for yourself, updating the kernel, reinstalling grub, and reinstalling Ubuntu were all actions that allowed me to rule out software as being the cause of this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.