0

I am trying to run this app; https://github.com/gioargyr/docker-kr-suite But, when i run "docker run deneme1" (deneme1 refers my repository name) it is waiting for some commands or something. But when i tried giving a command like "ls" or "pwd" nothing happened. Thanks for your answer.

sudo docker run deneme1
# This file controls: which hosts are allowed to connect, how clients
# host       DATABASE  USER  ADDRESS  METHOD  [OPTIONS]
# hostssl    DATABASE  USER  ADDRESS  METHOD  [OPTIONS]
# hostnossl  DATABASE  USER  ADDRESS  METHOD  [OPTIONS]
# socket, "host" is either a plain or SSL-encrypted TCP/IP socket,
# "hostssl" is an SSL-encrypted TCP/IP socket, and "hostnossl" is a
# ADDRESS specifies the set of hosts the record matches.  It can be a
# host name, or it is made up of an IP address and a CIDR mask that is
# specifies the number of significant bits in the mask.  A host name
# that starts with a dot (.) matches a suffix of the actual host name.
# columns to specify the set of hosts.  Instead of a CIDR-address, you
# can write "samehost" to match any of the server's own IP addresses,
# "host" records.  In that case you will also need to make PostgreSQL
host    all             all             127.0.0.1/32            md5
host    all             all             ::1/128                 md5
# Allow replication connections from localhost, by a user with the
#host    replication     postgres        127.0.0.1/32            md5
#host    replication     postgres        ::1/128                 md5
host     all     all     0.0.0.0/0   md5
#listen_addresses = 'localhost'     # what IP address(es) to listen on;
listen_addresses='*'
2019-04-08 17:56:49.732 UTC [13] LOG:  database system was shut down at 2019-04-08 17:08:00 UTC
2019-04-08 17:56:50.022 UTC [13] LOG:  MultiXact member wraparound protections are now enabled
2019-04-08 17:56:50.025 UTC [17] LOG:  autovacuum launcher started
2019-04-08 17:56:50.026 UTC [12] LOG:  database system is ready to accept connections
0

Try like this:

docker search ubuntu
docker pull ubuntu
docker run ubuntu
docker images

Thats the way you use docker.

To create a repository, sign into Docker Hub, click on Repositories then Create Repo: dockerhub

Create repo

When creating a new repository, you can choose to put it in your Docker ID namespace, or that of any Organization that you are in the “Owners” team. The Repository Name needs to be unique in that namespace, can be two to 255 characters, and can only contain lowercase letters, numbers or - and _.

The “Short Description” of 100 characters is used in the search results, while the “Full Description” can be used as the Readme for the repository, and can use Markdown to add simple formatting.

After you hit the “Create” button, you then need to docker push images to that Hub based repository.

Pushing a Docker container image to Docker Hub

To push a repository to the Docker Hub, you must name your local image using your Docker Hub username, and the repository name that you created through Docker Hub on the web.

You can add multiple images to a repository, by adding a specific : to it (for example docs/base:testing). If it’s not specified, the tag defaults to latest.

You can name your local images either when you build it, using docker build -t /[:], by re-tagging an existing local image docker tag /[:], or by using docker commit /[:] to commit changes.

Now you can push this repository to the registry designated by its name or tag.

docker push <hub-user>/<repo-name>:<tag>
  • sudo docker pull deneme1 Using default tag: latest Error response from daemon: pull access denied for deneme1, repository does not exist or may require 'docker login' – fury Apr 8 at 18:13
  • And the repo i created is gone after reboot PC. – fury Apr 8 at 18:15
  • where is your repo? Github? Locally? Dockerhub? – An0n Apr 8 at 18:17
  • i mean with repo is Repository which is docker create. – fury Apr 8 at 18:18
  • i mean showed after "docker images" – fury Apr 8 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.