0

I am trying to install this program for my master thesis; https://github.com/gioargyr/docker-kr-suite but i can't understand how exactly run it. I have cloned it, then run this command in termninal as README mentioned; "[sudo] docker build -t docker-image-name ." Then these errors occured. https://imgur.com/VO9OyTT

Do you have any idea how to install and run this program appropriately?

Thanks for your help.

  • Which version of Ubuntu are you using? Please copy and paste the text from the terminal (including the command, ouput and errors) into your question above. Do not put images of texts. – user68186 Apr 8 '19 at 16:55
  • I am using Disco Dingo. – fury Apr 8 '19 at 16:57
  • Disco is not released yet and thus off-topic. Why do you have "trusty" repositories in your sources? Those won't work for Disco. – user68186 Apr 8 '19 at 16:59
  • I tried it with trusty version also. – fury Apr 8 '19 at 16:59
  • Is the screenshot from trusty or disco? – user68186 Apr 8 '19 at 17:00
0

Like this :

sudo apt update
sudo apt install apt-transport-https ca-certificates curl software-properties-common
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
sudo add-apt-repository "deb [arch=amd64] https://download.docker.com/linux/ubuntu bionic stable"
sudo apt update
apt-cache policy docker-ce
sudo apt install docker-ce

To check the status:

sudo systemctl status docker

Optional: add $USER to docker group (make sure to log out and back in after)

sudo groupadd docker
sudo usermod -aG docker $USER
sudo systemctl restart docker
| improve this answer | |
  • Problem is solved. Thanks for answer again. – fury Apr 8 '19 at 17:26
  • Can You accept the answer if it solved your problem? Thanks😉 – An0n Apr 8 '19 at 17:45
0
    # This file controls: which hosts are allowed to connect, how clients
# host       DATABASE  USER  ADDRESS  METHOD  [OPTIONS]
# hostssl    DATABASE  USER  ADDRESS  METHOD  [OPTIONS]
# hostnossl  DATABASE  USER  ADDRESS  METHOD  [OPTIONS]
# socket, "host" is either a plain or SSL-encrypted TCP/IP socket,
# "hostssl" is an SSL-encrypted TCP/IP socket, and "hostnossl" is a
# ADDRESS specifies the set of hosts the record matches.  It can be a
# host name, or it is made up of an IP address and a CIDR mask that is
# specifies the number of significant bits in the mask.  A host name
# that starts with a dot (.) matches a suffix of the actual host name.
# columns to specify the set of hosts.  Instead of a CIDR-address, you
# can write "samehost" to match any of the server's own IP addresses,
# "host" records.  In that case you will also need to make PostgreSQL
host    all             all             127.0.0.1/32            md5
host    all             all             ::1/128                 md5
# Allow replication connections from localhost, by a user with the
#host    replication     postgres        127.0.0.1/32            md5
#host    replication     postgres        ::1/128                 md5
host     all     all     0.0.0.0/0   md5
#listen_addresses = 'localhost'     # what IP address(es) to listen on;
listen_addresses='*'
2019-04-08 17:22:57.038 UTC [13] LOG:  database system was shut down at 2019-04-08 17:08:00 UTC
2019-04-08 17:22:57.296 UTC [13] LOG:  MultiXact member wraparound protections are now enabled
2019-04-08 17:22:57.299 UTC [17] LOG:  autovacuum launcher started
2019-04-08 17:22:57.299 UTC [12] LOG:  database system is ready to accept connections

After solving problem; i run "docker run " and i take these lines. How can i use it, because once i run a command like "ls" nothing happened.

| improve this answer | |
  • You need to make a user for docker. Also to see the commands type just “docker”. – An0n Apr 8 '19 at 17:47
  • how can i make a user? – fury Apr 8 '19 at 17:48
  • Check optional in my answer. – An0n Apr 8 '19 at 17:49
  • What happens when you type: “docker run hello-world” – An0n Apr 8 '19 at 17:50
  • "Hello from Docker! This message shows that your installation appears to be working correctly. " – fury Apr 8 '19 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.