6

I had similar problems to the original poster of

How to install delegate libraries for Image Magick 7.0.7

  • No Delegates after building 7.0.8-37.

I installed all the 240mb odd libraries and the 2nd lot that included 'libheif-dev' When I tried to use the single (big) command it failed with a '404' error so I used the instructions from the IM website. The 'make' failed with

.....
CC       coders/MagickCore_libMagickCore_7_Q16HDRI_la-heic.lo
coders/heic.c: In function ‘WriteProfile’:
coders/heic.c:546:18: warning: implicit declaration of function ‘heif_context_add_exif_metadata’; did you mean ‘heif_image_handle_get_metadata’? [-Wimplicit-function-declaration]
.... etc
 *** [coders/MagickCore_libMagickCore_7_Q16HDRI_la-heic.lo] Error 1
make[1]: Leaving directory '/home/xxxx/imagemagick_build/ImageMagick-7.0.8-39'
Makefile:5761: recipe for target 'all' failed
make: *** [all] Error 

Not having an Iphone I decided I didn't need 'HEIC' and removed 'libheif-dev' and tried again result a new ImageMagick :

Version: ImageMagick 7.0.8-39 Q16 x86_64 2019-04-08 https://imagemagick.org

I can start playing with it now - at least it now displays jpegs.

Thanks Andrew46

5

Hopefully me struggling for way too long getting mogrify up and running will help someone else.

Compiling imagemagick with HEIC support from clean install of Ubuntu:

$ sudo sed -Ei 's/^# deb-src /deb-src /' /etc/apt/sources.list
$ sudo apt-get update
$ sudo apt-get install build-essential autoconf git-core
$ sudo apt-get build-dep imagemagick libde265 libheif
$ cd /usr/src/ 
$ sudo git clone https://github.com/strukturag/libde265.git  
$ sudo git clone https://github.com/strukturag/libheif.git 
$ cd libde265/ 
$ sudo ./autogen.sh 
$ sudo ./configure 
$ sudo make –j4  
$ sudo make install 
$ cd /usr/src/libheif/ 
$ sudo ./autogen.sh 
$ sudo ./configure 
$ sudo make –j4  
$ sudo make install 
$ cd /usr/src/ 
$ sudo wget https://www.imagemagick.org/download/ImageMagick.tar.gz 
$ sudo tar xf ImageMagick.tar.gz 
$ cd ImageMagick-7* 
$ sudo ./configure --with-heic=yes 
$ sudo make –j4  
$ sudo make install  
$ sudo ldconfig  
$ mogrify --version 
# heic should appear in the Delegates line 

Additional References:

https://linuxconfig.org/how-to-install-imagemagick-7-on-ubuntu-18-04-linux

https://github.com/ImageMagick/ImageMagick/issues/1470

https://github.com/strukturag/libheif/blob/master/README.md

https://github.com/strukturag/libde265/blob/master/README.md

1
  • works smoothly on a stock ubuntu, thanks! – bekce May 19 at 17:20
3

I had the same problem under Ubuntu 18.04 when trying to compile the latest version of ImageMagick 7.0.8. The solution was to manually compile and install the latest version of libheif from here. After this, the compilation succeeded. Remember to uninstall the default package of libheif supplied by Ubuntu first, both libheif and libheif-dev.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.