17

I downloaded Anydesk (4.0.1 64bit) on both my laptop and desktop and when I run it from one pc and try to connect to the other I get the following error

remote server display not supported e.g Wayland.

Both PCs are running Ubuntu 18.04.2. I tried search for a solution, I found a suggestion to disable Wayland in the file /etc/gdm3/custom.conf setting WaylandEnable=false but nothing changed.

1
  • WaylandEnable=false worked for me after reboot – spacebiker Apr 10 at 18:08
21

After installing Anydesk on my Ubuntu 18.04 server and trying to connect from a Mac, I would get a display_server_not_supported error. I was able to resolve this by going into the /etc/gdm3/custom.conf file and changing:

[daemon]
    # Enabling automatic login
    AutomaticLoginEnable=true
    AutomaticLogin=$USERNAME

After rebooting the Ubuntu server, Anydesk now connects and shows the login screen and I can login just fine.

1
  • 4
    For anyone coming across this answer, don't forget to also put WaylandEnable=false in the config as the question-asker mentioned. Both are required. – Chris Hayes Jan 22 at 21:38
0

I had the same problem connecting Anydesk Windows 7 to Anydesk UBUNTU. At some point Ubuntu and Wayland started from some cause. As you wrote WaylandEnable = false did not help. It helped me to opt out of the user and when I sign in before I confirm the password, choose (under the gear) only pure Ubuntu without Wayland. You can try if it also works for you.

1
  • hmm thanks for your reply. I use a multiuser setup with i3wm instead of Ubuntu desktop so I don't have this gear option to suppress wayland. I have to do it with some configuration parameters I guess (for example inside .xsession file) and don't know how! – Konstantinos A Apr 29 '19 at 9:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.