i am using ubuntu 11.10 and i once i logged in and the screen flashed for a sec and came back to the same screen it is happening again and again. i put the ubuntu cd and almost reinstalled it while i got this thought "lets try again" i tried again and luckly it came. i immediately came here without another log off and asked you guys. how do i correct it such that i wont be having problems in future?????

  • Sounds like a hardware issue, not a software issue. Mar 15, 2012 at 11:11
  • Or a lock file issue after the initial install. Or even a Graphics Card driver issue. Can you choose the option to load Gnome Classic, or what are your options in that user menu at the login screen? Mar 15, 2012 at 11:57
  • i dont get it.what lock file issue??and by the way, i dont have a graphic card.how do i load gnome classic????in the user menu, i have my user my moms, my dads.i can login from that users but only mine is an admin user.and then in my user there is a settings button which gives 2 options-ubuntu and ubuntu 2d
    – rakshith
    Mar 15, 2012 at 12:05
  • 2
    Try deleting .Xauthority from your HOME folder. I know it sounds crazy, and personally, I have no idea what it actually does, but I had this exact same problem. Deleting this file from the Ctrl-Alt-F1 command at the login screen allowed me to then log in with no problem. Don't ask me how it works...I can lead you to another post if you want. But, it worked for me...but I can't guarantee success for you. Mar 18, 2012 at 8:38

4 Answers 4


Thanks Ryan McClure!! I had the same logging in problem and it worked for me!!

I had the same problem as rakshith after when ubuntu hung-up while using firefox.I tried many times, but the same log-in screen flashed again and again. After reading this post, i tried Ctrl+Alt+F1 and deleted the .Xauthority file, rebooted it and my next log-in succesfully brought up the GUI.


I also was returned to login screen, but for me it was xorg configuration issue. Here is the solution:

I was able to run Xfce manager. Then i run from terminal or alt+f2:


go to 'X Server Display Configuration', click 'Reset' button, then 'Save to X Configuration file' In new window uncheck 'merge..' option and click 'save' button.


This happens when X runs into an error in the course of executing its startup scripts. In my case, the startup script was /etc/X11/Xsession. It used sh as its chosen shell to interpret the commands startup scripts. sh corresponds to dash on Ubuntu 12.04. It didn't recognize some bash-specific commands and crashed.

Ideally, there would be some sort of error indication in the UI that would let the user know what has happened. See this bug for more context.

The file ~/.xsession-errors tipped me off and I was able to fix the offending line soon after. Do you see a similarly named file in your home directory? You may have to log into the shell using Ctrl-Option-F1 like the others have suggested.


You might have deleted the user's directory inside /home.

Press Ctrl+Alt+F2

ls /home 

If you don't see any directory then create a directory of your username.

sudo mkdir /home/<username>  

Press Ctrl+Alt+F7 to go back to the login screen.

That's it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .