At once I will say that I am new to using linux. I use Ubuntu 18.04.2 LTS. And I had a problem with the desktop. The desktop sometimes slows down and folders do not always drag to another location and freezing. What could be the problem?

For @Marmayogi request

free --giga
              total        used        free      shared  buff/cache   available
Mem:              8           1           5           0           1           5
Swap:             2           0           2
sudo lshw -short -class memory
H/W path       Device     Class          Description
/0/0                      memory         64KiB BIOS
/0/8                      memory         8GiB System Memory
/0/8/0                    memory         8GiB SODIMM DDR4 Synchronous 2400 MHz (0,
/0/8/1                    memory         [empty]
/0/8/2                    memory         [empty]
/0/8/3                    memory         [empty]
/0/e                      memory         128KiB L1 cache
/0/f                      memory         512KiB L2 cache
/0/10                     memory         4MiB L3 cache
/0/100/1f.2               memory         Memory controller

For @heynnema request

ls -al ~/.local/share/gnome-shell/extensions
total 12
drwxrwxr-x 3 zuodion zuodion 4096 apr  6 10:25 .
drwx------ 3 zuodion zuodion 4096 apr  6 19:10 ..
drwxrwxr-x 3 zuodion zuodion 4096 apr  6 10:25 user-theme@gnome-shell-extensions.gcampax.github.com
  • Comments are not for extended discussion; this conversation has been moved to chat. – terdon Apr 7 '19 at 14:09
  • @zuodion are you opening up and using multiple applications on your ubuntu system concurrently? What about your browser activities? Are you a heavy internet surfer? Are you often keeping up multiple web pages on your browser concurrently? – Marmayogi Apr 7 '19 at 15:21
  • @Marmayogi This problem occurs even if applications or browsers are not running. – zuodion Apr 7 '19 at 16:13
  • @zuodion you have a 2 GB swap already. You can have multiple swap files under Ubuntu. Why don't you create an additional 4 GB swap file and verify the problem is solved or not. Later, it is found that this does not yield desired results, then you can always delete it! No harm done! To create a swap file, refer How to create a SWAP file. Please give a try! – Marmayogi Apr 7 '19 at 16:31
  • @zuodion I just got caught up with the chat... and it sounds like 18.10 worked for you, yes? – heynnema Apr 7 '19 at 17:13

Complete these tasks...

  • select "Ubuntu" environment at the login screen cogwheel

  • upgrade the BIOS to 313/314 https://www.asus.com/ph/Laptops/ASUS-Vivobook-X556UQ/HelpDesk_BIOS/

  • run memtest from a Ubuntu Live DVD/USB (complete 4/4 passes, if you have the time)

  • disable the discrete video card, as it's broken (disable the driver, or in the BIOS)

  • disable wayland, like so...

You may have a problem with an older computer, with an older GPU. Try this...

  • boot to recovery mode
  • choose root access


sudo mount -o remount,rw /      # to remount the disk r/w

sudo pico /etc/gdm3/custom.conf # edit this file





Then reboot.

Update #1:

We booted to a Ubuntu Live 18.10 USB, and no problems were seen.

Update #2:

Before upgrading to 18.10, to see if that fixes the problem with the desktop, we should do a fsck first to check your file system, then you can use Software Updater to do the upgrade. Of course... having a good backup never hurts... just in case something goes wrong :-)

For 18.04 or newer...

  • boot to a Ubuntu Live DVD/USB
  • open a terminal window
  • type sudo fdisk -l
  • identify the /dev/XXXX device name for your "Linux Filesystem"
  • type sudo fsck -f /dev/XXXX # replacing XXXX with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot

Update #3:

To eliminate the possibility of bad blocks on your HDD causing your problem, we'll test to find any bad blocks.

First, start the Disks app, select your HDD, then go to the "hamburger" icon, and select SMART Data & Tests. Review the data, pay attention to items that include the word "sector". Then run the tests.

Also, lets check syslog for disk errors... grep -i sda /var/log/syslog*. Copy/paste that output into imgur.com (or paste.ubuntu.com) if they're lengthy.

Note: It's always a good idea to have backup of your important Ubuntu files.

So do this to test for bad blocks... (this may take a while)...

Boot to a Ubuntu Live DVD/USB.

Open terminal...

Use the fdisk method from Update #2 to figure out /dev/sdaX.

sudo e2fsck -fcky /dev/sdaX # read-only test


sudo e2fsck -fccky /dev/sdaX # non-destructive read/write test (recommended)

The -k is important, because it saves the previous bad block table, and adds any new bad blocks to that table. Without -k, you loose all of the prior bad block information.

The -fccky parameter...

   -f     Force checking even if the file system seems clean.

   -c     This option causes e2fsck to use badblocks(8) program  to  do  a
          read-only  scan  of  the device in order to find any bad blocks.
          If any bad blocks are found, they are added  to  the  bad  block
          inode  to  prevent them from being allocated to a file or direc‐
          tory.  If this option is specified twice,  then  the  bad  block
          scan will be done using a non-destructive read-write test.

   -k     When combined with the -c option, any existing bad blocks in the
          bad blocks list are preserved, and any new bad blocks  found  by
          running  badblocks(8)  will  be added to the existing bad blocks

   -y     Assume  an answer of `yes' to all questions; allows e2fsck to be
          used non-interactively.  This option may not be specified at the
          same time as the -n or -p options.

Update #4:

During/after the bad block scan, the drive died. Will require replacement.


If that problem occurs in a virtual machine, I had a similar problem. In vmbox, the problem can be resolved by changing the number of processors to 2 (or more depending on your system) from Settings>System>Processors.

  • 1
    I use Ubuntu as main OS without VM – zuodion Apr 6 '19 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.