I've tried for hours to install nvidia drivers for my laptop. The standard nvidia-390, the newer nvidia-418 through the repo, various other versions, the .run files from Nvidia's website, tried changing into lightdm, tried the various grub parameters like nomodeset etc. Last thing I tried was installing nvidia-384 because why the hell not at this point, which resulted in a login loop. Not the first time this is happening either, the standard nvidia-390 does the same and I have no idea why. Has someone managed to install nvidia drivers in a similar system that could help me? Thank you. Edit: I've disabled secure boot, so unless my BIOS is lying to me, this shouldn't be an issue...

EDIT 2: After installing nvidia-driver-418 I can boot the system, but the command nvidia-settings give me this output:

ERROR: Unable to load info from any available system

(nvidia-settings:2477): GLib-GObject-CRITICAL **: 12:22:32.065: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 12:22:32.070: PRIME: No offloading required. Abort
** Message: 12:22:32.070: PRIME: is it supported? no

And the nvidia-settings window is empty. Any ideas?

marked as duplicate by mikewhatever, Eric Carvalho, Fabby, N0rbert, mniess Apr 13 at 13:30

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


I was faced with a similar problem while trying to install the Nvidia drivers for the RTX 2070.

May I suggest you look at how I solved the problem in this post, in case it helps.

The two important things to note are:

  • You need to install a driver which is compatible with your graphics card. You can check compatible drivers on the Nvidia website. From what I see there, the latest version 418 supports your graphics card (but please check yourself to make sure).
  • Make sure you use the command sudo apt-get install nvidia-driver-418 when installing your driver (not sudo apt-get install nvidia-418 which is obsolete).

Please let me know how if it worked.

  • Thanks for the reply. This does not work unfortunately, at least not the last 3 or so times I've tried it (I always purge nvidia packages beforehand, so it's not that). I'm now reinstalling Ubuntu but with the third-party software option checked, I think I read somewhere that this may help. If it doesn't change anything, I'll install 418 and get back to you. – Antonis Karvelas Apr 6 at 9:05
  • Tried installing nvidia-driver-418, didn't work, please see edited post. – Antonis Karvelas Apr 6 at 9:24
  • I don't know if it can help, but have you tried blacklisting nouveau? Check out Marmayogi's answer on this post for instructions. – johnwolf1987 Apr 6 at 9:27
  • Alternatively, you can try to update kernel. See Frank's answer on the same post for instructions. I hope one of these options work... – johnwolf1987 Apr 6 at 9:30
  • Updating to newest kernel and blacklisting nouveau doesn't work. Currently stuck at black screen on boot... – Antonis Karvelas Apr 6 at 10:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.