0

I have tried to update ubuntu machine from 16.0.4.5 to 18.0.4 (by following the standard procedure to run do-release-upgrade). Despite several attempts post upgrade machine does not boot up. A black screen keeps blinking after UTMP service started.

black screen
Ubuntu 18.04 black screen in VMware

Here is what I have tried:

  1. Updated the owner of .Xuathority and .ICEAuthority.
  2. Verified that tmp has enough permissions.
  3. Uncomment WayLand in custom.conf under /etc/gdm3/ so that Xorg is used instead of wayland
  4. Switched from gdm3 to lightdm.
    I noticed a different issue - Ubuntu boots till login. Post entering the credentials system comes back to login window. I tried couple of suggestions online to fix this, but none of the solutions solved problem.

I tried to install Ubuntu with the following virtual machine applications:

  1. VMware Fusion for Mac - 11.0.2
  2. VMware ESXi - 6.5

Ensured that the computer has the minimum configuration suggested for Ubuntu 18.04.

  • Did you try booting to runlevel 3 (i.e. without graphics)? – Elias Apr 5 at 16:42
  • 1
    Yeah, booting into run level 3 works perfectly fine. – nihar Apr 8 at 6:14
  • Might be worth checking if this helps: askubuntu.com/a/1131525/874649 (installing nvidia-driver-390) – Elias Apr 8 at 11:56
  • I run my ubunutu on virtual machine(VMWare Fusion). Does this installation still need nvidia graphics driver? Anyways I tried to install nvidia; that does not solve my issue eitherr :( – nihar Apr 9 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.