I'm attempting to restore from a previous backup but the restore keeps asking me for an Encrypted Password. I enter what I want it to be but it shows up some thirty seconds later to ask again. Why is this?


Sounds like a bug? File one at https://launchpad.net/deja-dup/+filebug, provide the logs it asks for, and I might be able to help.

One thing though is that you mention entering what you want the password to be? When restoring, you should be entering the same password you used when originally backing up.

  • Ended up not using Deja-Dup and just digging out old externals and filling them up. I wish I had the time to dig into it but maybe someone will come across this. – John McKean Pruitt Mar 18 '12 at 19:54

I had the exact same symptoms. My solution was to dig through my records to find an old password I'd used on a previous backup (with Ubuntu One, not deja-dup directly), install ubuntu one on the destination (restore) machine, and then enter that old password during the restoration of that recent backup file. Filed a bug report https://bugs.launchpad.net/deja-dup/+bug/1035924 as suggested by @MichaelTerry


I'm in a big - holy $#^^@# i just lost a ton of files mess. I'm currently restoring some from ubuntu one and got this Encryption Password prompt. It really had me worried and I tried some of my old passwords and they didn't work. I just reset my ubuntu one password, i know that password was not in use when I created these backups. My brand new, just reset, password worked here - so it may not be some old password you set your backups with, try your current ubuntu one password.

(i'm sure you're over this issue, but google led me to this thread, so i hope it helps the next person)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.