0

My internet connection is perfect, and I had also tried using the best mirror for downloading the updates, yet apt-get update and apt-get upgrade are extremely slow- it gets stuck with "reading headers".

I've also tried disabling ipv6 system wide, by following the instructions here: Apt downloads very slow . Could this signify the behavior of some kind of a malware?

Even installing packages run extremely slow (when I run them as spt-get install). I tested out the speed with a virtual machine instance (which runs Ubuntu 16, while the system I'm talking about here runs Ubuntu 18), and the speed was fine- as usual. What could be causing this? Is it a sign of malware activity? I tried using rkhunter, and it wasn't very helpful.

The download speed usually starts of being fast, and then becomes progressively slow. Thus, when I keep cancelling the process with ctrl+c and rerunning the process, I'm able to get it updated easily. The initially logged speed is actually fine. But for some reason, it becomes slower over time.

This is where I'm stuck right now:

Hit:1 http://es-mirrors.evowise.com/ubuntu bionic InRelease
Hit:2 http://es-mirrors.evowise.com/ubuntu bionic-updates InRelease            
Hit:3 http://es-mirrors.evowise.com/ubuntu bionic-backports InRelease          
Hit:4 http://es-mirrors.evowise.com/ubuntu bionic-security InRelease           
Ign:5 http://dl.google.com/linux/chrome/deb stable InRelease                   
Get:6 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease [6,257 B]      
Ign:7 http://dl.google.com/linux/talkplugin/deb stable InRelease               
Err:6 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease                
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 76F1A20FF987672F
Hit:8 http://dl.google.com/linux/chrome/deb stable Release                     
Hit:9 http://ppa.launchpad.net/libreoffice/ppa/ubuntu bionic InRelease 
Hit:11 http://dl.google.com/linux/talkplugin/deb stable Release                
Hit:13 http://ppa.launchpad.net/mscore-ubuntu/mscore-stable/ubuntu bionic InRelease
Hit:14 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu bionic InRelease
Hit:15 http://ppa.launchpad.net/webupd8team/atom/ubuntu bionic InRelease       
Hit:16 http://ppa.launchpad.net/wireshark-dev/stable/ubuntu bionic InRelease   
Get:17 http://es-mirrors.evowise.com/ubuntu bionic amd64 Contents (deb) [39.5 MB]
Get:17 http://es-mirrors.evowise.com/ubuntu bionic amd64 Contents (deb) [39.5 MB]
Get:17 http://es-mirrors.evowise.com/ubuntu bionic amd64 Contents (deb) [39.5 MB]
23% [17 Contents-amd64 10.2 MB/39.5 MB 26%]^C

Snapshot of the terminal

And I had also checked to see if it was the issue of the server that is being connected. For that, I had tried downloading the same file from this path: es-mirrors.evowise.com/ubuntu/dists/bionic-updates/Contents-amd64.gz directly from the browser. Yes it was slow, but the speed was around 35 to 75 kbps. Not bad actually, for the 10kbps or 8kbps I get, in the terminal. Could this be caused by a malware? Or is there something broken, or some application interfering with the download process?

I'm still having this problem. The download speed goes down to a few kbps or even few bytes per second. I also tried apt-get clean and every other solution I could find. Please tell me what should I do. Thanks!

  • Does this happen to anyone else? Am I the only person facing this? – Sreram Apr 9 at 6:42
  • I am also getting this periodically. It took me 4 days to run an apt upgrade last week.... with download speeds eventually going down into the singular Bytes/s... And it was only ppas from launchpad that had this issue. – Douglas Gaskell May 4 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.