terminal will not load and "if" it does it never loads a prompt ex: username:machinename#, only the windows frame, file menu and a blinking cursor, cant type anything, cant run commands, have no idea how to fix this without being able to run any commands, all "how-tos" start with run this command ;) cant anyone help, I'm afraid I'm going to have to blow out my system due to this. running ubuntu 18.04.2

enter image description here enter image description here

  • Have you purged or removed some package recently? Go to TTY mode using Ctrl+Alt+Fx (where Fx can vary from F1-F7) and try to reinstall gnome-terminal using sudo apt install --reinstall gnome-terminal.
    – Kulfy
    Apr 4, 2019 at 19:17
  • I would love to purge or reinstall but can't terminal is dead, and synaptic-package manger wont open, i'm going no where
    – dEadRaVens
    Apr 4, 2019 at 19:19
  • I tried to boot in recovery mode and ran the dkpg repair but no help
    – dEadRaVens
    Apr 4, 2019 at 19:20
  • Do you mean you can't open TTY mode as well?
    – Kulfy
    Apr 4, 2019 at 19:21
  • 1
    Some background also might be helpful. Is this a machine you've been using for a long time? Or a brand new install? Were you performing an update when this broke? Did it ever work? What were you doing when it broke? Etc. Apr 4, 2019 at 19:44

3 Answers 3


Partial answer...

From the comments...

User is having problem with various applications not running correctly.

We created a new, temporary "guest" account, logged in there, and the applications are working there. There's something wrong in the original user's account.

We've eliminated the .local and .config folders as suspect. We're doing more testing now...

  • i just tried this, but same issue, i'm using gmone 3, all default ubuntu 18.04.2 options I stopped tweaking my workstation years ago. the system logs in automatically.
    – dEadRaVens
    Apr 4, 2019 at 20:16
  • @dEadRaVens create a temporary "guest" account, login there, and see if you have the same problem(s). Report back.
    – heynnema
    Apr 4, 2019 at 20:40
  • ok it freezes on black screen if i "switched user" but it did log in if I "logged out" to a new user, and terminal opens fine and works ;) should i try uninstalling it here now, or does this prove that terminal is fine, and something is wrong with the other user profile?
    – dEadRaVens
    Apr 4, 2019 at 21:01
  • 1
    It means there's something wrong in your original user home folder... probably something in .local or .config. Using the FILES application, rename .local to .local.HOLD. Log out. Log in. Retry terminal. If it works, something is wrong in the .local.HOLD folder. Do the same for the .config folder. But only do one folder at a time. Report back.
    – heynnema
    Apr 4, 2019 at 21:11
  • .local didnt have any effect, .config changed everything "desktop wise" but terminal still no go on either change, now it doesnt open at all not even a dummy window. I only changed one folder at a time with logging out and in between each change, and change the .local folder back to original before changing the .config folder, hope that was right.
    – dEadRaVens
    Apr 4, 2019 at 21:24

Press Ctrl+Alt+F1 and then run the following commands:

cp ~/.bashrc ~/.bashrc.bak
cp /etc/skel/.bashrc ~/
source ~/.bashrc

If the terminal is not working with Ctrl+Alt+F1, try to change the content of ~/.bashrc manually.


In my case, I had to uncheck "Run a custom command instead of my shell" in the Edit -> Preference -> Command tab. See the image below.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .