3

I'm new to Kubuntu, having switched from Mint Cinnamon in January, but I have been having problems trying to get my LogiCool K750 Keyboard working correctly. Logicool is the Japanese brand for Logitech and the keyboard I have is the Japanese version as I wish to change between English and Japanese (both writing forms).

I've seen a few threads on here, the most useful being How do I change default keyboard layout (not input method) in Ubuntu 16.04? as well as KubuntuForms.net but thus far none of them actually work. Whilst I have been able to add Japanese language support, I can't set up the keyboard to work correctly and the various variants do not include a layout that is actually correct for any Japanese keyboard I've seen.

I've included an image of the K750 layout and you'll notice that the slashes are next to each other on the right. I've not seen any layouts that support this for Kubuntu whereas it just works on Linux Mint but I don't want to have to swap back as I prefer Plasma5 and KDE.

If anyone can help I would appreciate the help as I'm rather stuck now and have run out of ideas over the last two months.

Update If I run im-config on both then that shows the same output

Current configuration for the input method:
 * Active configuration: missing (normally missing)
 * Normal automatic choice: ibus (normally ibus or fcitx or uim)
 * Override rule: zh_CN,fcitx:zh_TW,fcitx:zh_HK,fcitx:zh_SG,fcitx:ja_JP,fcitx:ko_KR,fcitx:vi_VN,fcitx
 * Current override choice:  (en_GB)
 * Current automatic choice: ibus
 * Number of valid choices: 3 (normally 1)
The override rule is defined in /etc/default/im-config.
The configuration set by im-config is activated by re-starting X.
Explicit selection is not required to enable the automatic configuration if the active one is default/auto/cjkv/missing.
  Available input methods: ibus fcitx xim
Unless you really need them all, please make sure to install only one input method tool.

** Update 2 **

So I've enabled keyboard support for English characters on the layout by going into iBus and then adding Japanese into the input method there as well as having it setup within the input method configuration from the keyboard icon in the taskbar. I have noted that keyboard settings within the system settings for layouts is still only showing GB English though so it's rather confusing as to which combinations are actually in use.

I've not figures out how to now enable the Japanese characters though even though ibus is set to JA (Japanese).

  • Do you remember which keyboard layout and keyboard model you had set on Linux Mint? AFAIK Mint uses XKB for this just like Kubuntu. – Gunnar Hjalmarsson Apr 4 at 9:37
  • @GunnarHjalmarsson I still have an old laptop with it set-up so I can check. From the gui side I can see the iBus settings in the system tray show ``` English - English (UK, extended WinKeys) Japanese - Japanese ``` Clicking about on the Japanese shows it's using a Japanese keyboard layout by Pen Huang The keyboard layout just shows as "Japanese" – Steve Mapes Apr 4 at 10:03
  • Can you please also show what the /etc/default/keyboard file looks like on the old machine. As regards typing Japanese, you probably want to install the ibus-mozc package, reboot, and then select Mozc in the IBus settings. – Gunnar Hjalmarsson Apr 4 at 13:54
  • Your Japanese keyboard layout is called OADG 109A ja.wikipedia.org/wiki/… And you can select your keyboard layout correctly by sudo dpkg-reconfigure keyboard-configuration You can delete GB keyboard layout if you do not use it. En - OADG English keyboard, Ja - ibus-mozc or fcitx-mozc to type Japanese characters which is too many for 109 keys and it does need an engine to help typing. – Sadaharu Wakisaka Apr 5 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.