0

I know that this question is asked before, but nothing seems to work. I have a double boot windows 10 - ubuntu 18.10 on the NVME and a 2nd 1 TB HDD drive (ntfs). Windows of course have permition on the HDD, but ubuntu dont (read-only).

I want to have read-write-execute permission as user (id=1000) on the HDD!

tried:

1) remount

sudo mount -o remount,rw <drive-name> <mount-point>

Sometimes works after 1st reboot, but after 2nd reboot, I had read-only permissions again

2) edit fstab

default entry:

/dev/disk/by-uuid/[disk-id] /path/to/mount auto nosuid,nodev,nofail,x-gvfs-show 0 0

changed to:

/dev/disk/by-uuid/[disk-id] /path/to/mount auto nosuid,rw,nodev,nofail,x-gvfs-show 0 0

,

/dev/disk/by-uuid/[disk-id] /path/to/mount auto nosuid,uid=1000,nodev,rw,nofail,x-gvfs-show

,

/dev/disk/by-uuid/[disk-id] /path/to/mount ntfs defaults

,

/dev/disk/by-uuid/[disk-id] /path/to/mount ntfs-3g defaults

,

dev/disk/by-uuid/[disk-id] /path/to/mount ntfs nosuid,uid=1000,nodev,rw,nofail,x-gvfs-show 0 0

3) chown

sudo chown -R -v user:user /path/to/mount

error: failed to change ownership of '/path/to/mount' from user:root to user:user ,

chown -R user /path/to/mount

didn't work

As far as I understand, perimssions are granded upon mount on boot time. So, the solution has to lie at fstab. But, the mount point is at /media/ (or by default at /mnt/) which are directories with only-root permissions, thus I tried to mount under /home/user/testDir, but got the error:

mount: /home/user/testDir: mount point not mounted or bad option

Any suggestions? Maybe, in how to properly edit fstab? Any help will be deeply apriciated and your karma will be vastly souped up!

  • Have you disabled fast boot in Windows? – user68186 Apr 3 at 11:38
  • If it's NTFS then you probably need to manage permissions on the Windows side. Have you tried creating an EXT4 partition to manage with Ubuntu? – DaveStSomeWhere Apr 3 at 11:55
  • Yes, disabling fast boot in Windows did work! Thank you both a lot! – Thanasis Mattas Apr 3 at 12:27
0

Most common cause is Fast Boot in Windows.
For that (in Windows) search Control Panel:

  • Choose what the power buttons do.
  • Choose Change settings that are currently unavailable.
  • Unselect Turn on fast startup (recommended) so that the checkmark disappears.
  • Click Save changes.
    Done.
  • As you may notice, I am a new contributor and I need 15+ reputation to upvote. – Thanasis Mattas Apr 3 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.